Problem installing MPlayer

Hi,
For a wile I havent posted anything, I was busy with my site but now I want to migrate definitive to SUSE, I want to use it for all kind of stuffs, to see a movie, to listen to a song, general stuff like that. I wanted to view some stuff on the net and I cant because it uses Windows Media Player to play that clip, I was looking on the net for something to view and I found MPlayer.
mplayerplug-in

I tried to install it but I cant, I tried to follow what it says but unfortunally for me I wasnt been enable to finish, I`m new in SUSE and hope that you understand me and try to teech me something.

I read this tutorial too: Playing wmv in Firefox HOWTO - openSUSE

But it gives me an error: http://i39.tinypic.com/24wfpyt.png

What to do ? I tried to install that libdirect but I can`t because it needs all other programs, etc, etc, a long list of programs.

Please tell me what to do, I want to learn not just to solve this problem and please be as explicit as you can.

Thanks and have a wonderful day.

Check if you have directfb installed

Yes, I do have it installed: http://i42.tinypic.com/b5sggy.png

post terminal output of

rpm -qi MPlayer

package MPlayer is not installed

Double check
Copy and paste the code I gave you.
Post the code if you get output:

If it still says Not Installed, open Yast software management
filter by repo
select packman
find MPlayer in the list and install