Problem installing Grub and suse11 on a macbook

Hi all,
I followed this article to install 4 OS into my mac book (Santa Rosa version):

when I run the partitioning tool under Suse and I create my partition for Suse firstly I receive following message:

“The disk label type on your system disk is GTP. Linux can
handle a GTP partition table fine but most BIOS versions cannot handle the disk label. To remove GPT disk label from your disk, use the menu entry “delete partition table and disk label” of the Expert menu options.”

If I do this, my partition table is deleted!

If I ignore the above message and go ahead, I get an error while the system configures the Grub boot loader - Error 22: No such partition.

Tried to install Ubuntu and FedoraCore both with Grub. In this case I do not encountered any issue.

So My question is: what wrong with Suse? Is this a bug? Why with the same conditions this problem append just during the Suse installation?

Goggling I didn’t find any good informations about this issue…


Same exact problem for myself… I am going to bump this in an effort to get some more exposure.

Unless the OP found a solution!

There’s a bug reported for this one. See the URL below for more info on this one.

Rgrds, Martijn