problem in reading my SDHC card !

Well, my problem is that I inserted one of my SD cards and I could read the data on it for a while…but when I tried copying data from it…it was suddenly unreadable according to openSUSE…
After that, whenever I insert my card…just some files with weird filenames are shown!!the filenames are comprised of wierd symbols…

For your info…I’m talkin bout a 4GB Transcend SDHC card.

What filesystem is it using?
As a first check, check that the filesystem is still in tact by using fsck to check the file system.
(man fsck or fsck --help will give you the command line switches)

Whatever you do - DO NOT try to run a disk repair util on the SD card!!! You WILL mess it up.

SD cards are notoriously problematic under Linux, it’s a problem with the drivers in the kernel.

You were lucky to actually get it to read it in the first place.

The only thing you can do is maybe try the latest kernel which should have updated drivers, and if that doesn’t work, simply forget about using SD cards until the driver that suits your SD card reader functions.

But I wouldn’t hold your breath on that one.

Some SD card readers work perfectly, some work sometimes, and others never work at all.

You could try an external USB reader, or if it’s a µSD card, you could get a USB converter (which is what I use).

Growbag
You mean I’ve been luck with my sd cards and readers so far!
Other than formatting the card sometimes to get it to read, I have had no problems so far.

Exactly :wink:

I’ve seen them work on an Asus laptop, and it worked after a kernel update on an old Acer I had, but other than that I’ve never had any luck on others, especially my main HP, and my Toshiba Tecra server :(.

I’m sure there is a list of fully working ones somewhere, no idea where though.

I believe it’s a bus timing issue, from what I have read, each card and controller have their own preferred access timing method/speed. Matching those speeds is the tricky part, plus some readers (I know the ones in Toshibas are like that) stick to the DRM rules, ie they have to have a hidden “authority” partition/area on the card in order for it to work properly.

Obviously that isn’t going to work under Linux because we don’t like conforming to that kind of nonsense ;).

This is a weird story. Just took a look, I have 6 different brands of SD cards, from 256 MB to 8 GB. They all work in my son’s PC, my three different brand external card readers, my main machine and my laptop. No matter which kernel, they all work.

This not to say the problem 's not there, just wondering.

I would say it’s the card reader then. Except for perhaps having to format the drive first time, I haven’t had a problem in most linux distros. I have had a problem with an sd card in the mmc slot on a dreambox linux sat receiver though, but that could just be the hardware.