Problem in connecting internet on OpenSUSE 12.2 Stable

I am a year old linux user of OPensuse. I was very happy with performance and overall look of opensuse 12.1 but just on yesterday I upgraded my opensuse 12.1 to 12.2 as I got relesed on yesterday. Before upgrading I used to connect internet through my modem ZTE k3570 using a script called sakis3g . this script used to work very well before upgradation But since I upgraded my os to 12.2 I am unable to connect net. the place where it used to show the list of available connected modems there it is showing now


I am only seeing above two words on list of available modem. I am unable to connect net by selecting any of above. I trid to connect using custom tty and wrote my /dev/ttyUSB1 where it is located but still I am unable to connect. I just get error saying " Unable to connect "

Later I tried to connect using wvdial , I configured my /etc/wvdial.conf according to my modem configuration but still its not working too.
While using wvdial I am getting error as "wvdial : utils/ 401:static void WvTaskman::_stackmaaster():Assertion ‘magic_number==-0*123678’ failed.

feeling so frustrated unable to connect net using network manager applet too… I am unable to connect net using any tool. Plz Help …Plz Plz
Any help is appriciated. Once again I am using opensuse 12.2 . Everthing was ok before on 12.1:(

So what is the script ? Please post the contents here in CODE tags.
Here’s a tutorial on how to do this :

Did you install anything additionally on 12.1 to make it work ?
Which desktop environment are you using ?

I had the very same error on a freshly installed openSUSE 12.2 64 bit. I noticed that “utils/wvstack” could be related
with the package wvstreams-4.4.1, therefore I tried and replaced wvstreams-4.4.1-81.1.3 with wvstreams-4.4.1-76.1.2 from openSUSE 12.1 (so same version, just different build numbers: you can find and download the package there: ) and it worked.
Of course it’s just a workaround but the only package that required wvstreams was wvdial itself, so no problem for me. If you want you can try, too, it might helps, just manually install the package for your architecture.


I know that some packages got patched to compile with gcc 4.7 for openSUSE 12.2 (a reason that delayed its release, if I remember well), it seams wvstreams is among those patched packages ( so, might be the case that this problem has something to do with the repackaging process? I’ll go check bugzilla and prepare a bug report, whence needed.