Problem HDA Intel STAC92xx and opensuse 11.2 64 bit

i do have sound, but the master control on the mixer does nothing and neither does the pcm control. i’d really like to fix this, but i’m stumped. i’ve loaded the latest drivers from the multimedia repository…

the only mixer control that works is for one of the speakers. i do run this same setup fine on opensuse 11.0 32 bit on the same hardware.

i am able to control the sound from amarok, if that helps.

thanks
kenb

qat:/tmp # rpm -qa | grep alsa
alsa-docs-1.0.21-3.2.noarch
alsa-driver-kmp-desktop-1.0.22.1.20100115_2.6.31.8_0.1-1.1.x86_64
alsa-tools-1.0.21-2.5.x86_64
alsa-driver-kmp-default-1.0.22.1.20100115_2.6.31.8_0.1-1.1.x86_64
alsa-plugins-1.0.21-3.3.x86_64
alsa-devel-1.0.21-3.2.x86_64
alsa-plugins-pulse-32bit-1.0.21-3.3.x86_64
alsa-oss-32bit-1.0.17-25.2.x86_64
alsa-firmware-1.0.20-3.2.noarch
alsa-oss-1.0.17-25.2.x86_64
alsa-plugins-32bit-1.0.21-3.3.x86_64
alsa-1.0.21-3.2.x86_64
alsa-plugins-pulse-1.0.21-3.3.x86_64
alsa-driver-doc-1.0.22.1.20100115-1.1.x86_64
alsa-utils-1.0.21-3.1.x86_64

qat:/tmp # rpm -qa | grep pulse
pulseaudio-module-lirc-0.9.19-2.3.x86_64
pulseaudio-utils-0.9.19-2.3.x86_64
libpulse0-32bit-0.9.19-2.3.x86_64
libpulse-browse0-0.9.19-2.3.x86_64
pulseaudio-module-x11-0.9.19-2.3.x86_64
libpulse-devel-0.9.19-2.3.x86_64
alsa-plugins-pulse-32bit-1.0.21-3.3.x86_64
pulseaudio-module-bluetooth-0.9.19-2.3.x86_64
libxine1-pulse-1.1.17-1.pm.24.2.x86_64
pulseaudio-module-zeroconf-0.9.19-2.3.x86_64
libpulse0-0.9.19-2.3.x86_64
libpulse-mainloop-glib0-0.9.19-2.3.x86_64
pulseaudio-0.9.19-2.3.x86_64
alsa-plugins-pulse-1.0.21-3.3.x86_64
pulseaudio-module-gconf-0.9.19-2.3.x86_64

qat:/tmp # rpm -q libasound2
libasound2-1.0.21-3.2.x86_64

qat:/tmp # uname -a
Linux qat 2.6.31.8-0.1-desktop #1 SMP PREEMPT 2009-12-15 23:55:40 +0100 x86_64 x86_64 x86_64 GNU/Linux

qat:/tmp # cat /etc/modprobe.d/sound
cat: /etc/modprobe.d/sound: No such file or directory

qat:/etc/modprobe.d # cat /etc/modprobe.d/50-sound.conf

options snd slots=snd-hda-intel

u1Nb.mu__efD1m12:82801JI (ICH10 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

Please, with your PC connected to the internet, can you also run the diagnostic script:

/usr/sbin/alsa-info.sh

and select SHARE/UPLOAD. When finished it will give you a URL. Please post here the URL. Just the URL.

If you do not see a URL, then run the script again with the no-upload option:

/usr/sbin/alsa-info.sh --no-upload

which will create the file /tmp/alsa-info.txt. Open that file alsa-info.txt with a text editor and copy its contents into a paste bin site such as PasteBin.be and press dump to submit it. That will give you a URL. Please post here the URL. Just the URL.

thank you…

here is the URL:

http://www.alsa-project.org/db/?f=4e55d4e66504fcf6c5c36aff8f3116127f5c6b40

Your PC has too many alsa-driver-kmp installed. One of them is causing problems. You need to remove alsa-driver-kmp-default which IS not for your kernel (I highlighted that in RED). That may also impact libraries installed from the correct one (alsa-driver-kmp-desktop which is in GREEN) so also remove alsa-driver-kmp-desktop and then re-install the driver alsa-driver-kmp-desktop.

Then you must reboot to unload and reload the alsa driver and test your sound.

However I also notice your other alsa applications are not updated to be consistent with the alsa driver-kmp-desktop. You should also try updating those as well. If you go to this repository:

http://download.opensuse.org/repositories/multimedia:/libs/openSUSE_11.2/

and look for and install the updated version for each of those alsa applications (where available) including libasound2. Then reboot and test. Note you should install those from YaST Software Management if the zypper command states the update not needed.

Note when testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:

speaker-test -Dplug:front -c2 -l5 -twav
Note Linux is case sensitive, and “D” is not the same as “d”. To stop the above test, while the konsole/xterm has the mouse focus, press on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you have basic sound established you can back off to lower volume levels. Note the test for surround sound is different.

If that test yields errors (and its not uncommon to get errors there), try instead this more simple test: speaker-test -c2 -l5 -twavYou should hear a female voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times. Its quite common that one of those speaker tests will work and one will NOT work, so don’t be distressed if that is the case. IF that test gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version … etc … ).

Or alternatively, for testing the simple playback, use aplay program. Prepare a WAV file (which I arbitrarily called “somefile.wav” and simply run like:

aplay -vv somefile.wav

With the option -vv, aplay shows the verbose information of the PCM device, and a VU-peak meter during playing the file.

Try those speaker-tests as both a regular user, and also with root permissions. If you have a headset, try with your headset plugged in, and also with your headset not plugged in (for speakers).

Now when adjusting your mixer to see if sound is present, please note:

!!Amixer output
!!-------------

!!-------Mixer controls for card 0 [Intel]

Card hw:0 ‘Intel’/‘HDA Intel at 0xd3320000 irq 28’
Mixer name : 'IDT 92HD73E1X5’
Components : ‘HDA:111d7676,80865001,00100202’
Simple mixer control ‘Master’,0
Playback channels: Mono
Mono: Playback 0 [0%] -48.00dB] [on]
Simple mixer control ‘Speaker’,0
Playback channels: Front Left - Front Right
Front Left: Playback 21 [33%] -32.25dB] [on]
Front Right: Playback 21 [33%] -32.25dB] [on]
Simple mixer control ‘Speaker’,1
Playback channels: Front Left - Front Right
Front Left: Playback 37 [58%] -20.25dB]** [off]**
Front Right: Playback 37 [58%] -20.25dB] [off]
Simple mixer control ‘Speaker’,3
Playback channels: Front Left - Front Right
Front Left: Playback 43 [67%] -15.75dB] [on]
Front Right: Playback 43 [67%] -15.75dB] [on]
You will need higher volume levels set on your Master volume and your speaker volume controls. You may also have to unmute one of your speaker volume controls.

Its possible after rebooting that you still do not have sound control you need. I note the STAC92XX is actually an IDT 92HD73E1X5 codec. Sometimes it is necessary to force a model option upon boot, … we can always try that by applying to the /etc/modprobe.d/50-sound.conf file one of the options from this list from the HD-Audio-Models.txt file for 1.0.22.1 of ALSA:

STAC92HD73*
===========
  ref		Reference board
  no-jd		BIOS setup but without jack-detection
  intel		Intel DG45* mobos
  dell-m6-amic	Dell desktops/laptops with analog mics
  dell-m6-dmic	Dell desktops/laptops with digital mics
  dell-m6	Dell desktops/laptops with both type of mics
  dell-eq	Dell desktops/laptops
  alienware	Alienware M17x
  auto		BIOS setup (default)

There is a very specific syntax needed here, and I can help you by giving you the syntax. BUT before trying that, if your sound control does not work properly, please reboot your PC and provide the output after a fresh reboot of your dmesg. You can do that by typing as a regular user from your /home/youruser directory:

dmesg > dmesg.txt

and open dmesg.txt with a text editor and copy and paste the output to a pastebin site such as PasteBin.be and press dump on that site to upload the contents and it will give you a URL. Post here the URL.

i’ve done as you’ve suggested. i did not find any alsa aps to upgrade, though, after removing and reinstalling the alsa kmp rpms.

same issue. i do have sound through “speaker 4” and can control it with only the speaker 4 slider. master, etc., have no effect. using the 2nd test i do hear a female voice saying “left”, “right”, etc…

i can play music through amarok and control the sound from that ap.

PasteBin.be

is the dmesg dump.

i appreciate the help!

kenb

Please look again !

alsa-tools-1.0.21-2.5.x86_64 to alsa-tools-1.0.22-6.1.x86_64.rpm
alsa-devel-1.0.21-3.2.x86_64 to alsa-devel-1.0.22-53.2.x86_64.rpm

etc … etc … for each one of the apps. Each has an update. Look !

PLEASE look again. Its all here:

http://download.opensuse.org/repositories/multimedia:/libs/openSUSE_11.2/x86_64/

and you add this repos:

http://download.opensuse.org/repositories/multimedia:/libs/openSUSE_11.2/

Clearly there is something you do not understand about using YaST ? ? (I’m speculating here) , as you state you do not see anything to update, yet the rpms are there.

well… i’ve only been using suse since v 9.1, but yes, clearly i don’t know how to use this new yast…

see:

[opensuse-factory] Anit-Vendor Change Extremism - Call for discussion](http://lists.opensuse.org/opensuse-factory/2009-10/msg00405.html)

:slight_smile:

i think i have it sorted now, but still no impact. i have sound, but all of the mixer controls except for speaker 4 are not operative. here’s where i am now:

rpm -qa | grep alsa
alsa-oss-32bit-1.0.17-27.1.x86_64
alsa-plugins-jack-32bit-1.0.22-19.1.x86_64
alsa-utils-1.0.21-19.1.x86_64
alsa-plugins-jack-1.0.22-19.1.x86_64
alsa-tools-1.0.22-6.1.x86_64
alsa-driver-kmp-desktop-1.0.22.1.20100117_2.6.31.8_0.1-1.1.x86_64
alsa-docs-1.0.22-53.2.noarch
alsa-plugins-pulse-1.0.22-19.1.x86_64
alsa-plugins-32bit-1.0.22-19.1.x86_64
alsa-oss-1.0.17-27.1.x86_64
alsa-1.0.22-53.2.x86_64
alsa-plugins-pulse-32bit-1.0.22-19.1.x86_64
alsa-plugins-speex-1.0.22-19.1.x86_64
alsa-firmware-1.0.20-7.1.noarch
alsa-plugins-1.0.22-19.1.x86_64
alsa-tools-devel-1.0.22-6.1.x86_64
alsa-tools-gui-1.0.22-6.1.x86_64
alsa-driver-doc-1.0.22.1.20100117-1.1.x86_64
alsa-plugins-samplerate-1.0.22-19.1.x86_64
alsa-devel-1.0.22-53.2.x86_64
alsa-plugins-samplerate-32bit-1.0.22-19.1.x86_64

rpm -qa | grep pulse
pulseaudio-0.9.21-37.1.x86_64
pulseaudio-utils-0.9.21-37.1.x86_64
pulseaudio-module-gconf-0.9.21-37.1.x86_64
pulseaudio-module-lirc-0.9.21-37.1.x86_64
pulseaudio-lang-0.9.21-37.1.noarch
alsa-plugins-pulse-1.0.22-19.1.x86_64
pulseaudio-module-x11-0.9.21-37.1.x86_64
libpulse0-0.9.21-37.1.x86_64
libpulse-mainloop-glib0-0.9.21-37.1.x86_64
pulseaudio-module-bluetooth-0.9.21-37.1.x86_64
alsa-plugins-pulse-32bit-1.0.22-19.1.x86_64
libxine1-pulse-1.1.17-1.pm.24.4.x86_64
pulseaudio-module-zeroconf-0.9.21-37.1.x86_64
libpulse-browse0-0.9.21-37.1.x86_64
libpulse-devel-0.9.21-37.1.x86_64
libpulse0-32bit-0.9.21-37.1.x86_64

rpm -qa | grep libasound2
libasound2-1.0.22-53.2.x86_64
libasound2-32bit-1.0.22-53.2.x86_64

cat /etc/modprobe.d/50-sound.conf

options snd slots=snd-hda-intel

u1Nb.mu__efD1m12:82801JI (ICH10 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

i ran the alsa test again:

http://www.alsa-project.org/db/?f=e656a0a15369b8b2b94956dc4817bee462d3f3fe

i know that speaker 4 is on and the master, etc., when this snapshot was taken are low. even with every control full up and not muted, “master” has no effect. the only control that does anything is “speaker 4” and it does work as it should.

this same setup works perfectly on 11.0 32 bit, so i have not tried plugging the speakers into a different jack.

thanks
kenb

I note this:

!!Amixer output
!!-------------
!!-------Mixer controls for card 0 [Intel]
Card hw:0 ‘Intel’/‘HDA Intel at 0xd3320000 irq 28’
Mixer name : 'IDT 92HD73E1X5’
Components : ‘HDA:111d7676,80865001,00100202’
Simple mixer control ‘Master’,0
Mono: Playback 15 [23%] -36.75dB] [on]
Simple mixer control ‘Speaker’,1
Front Left: Playback 0 **[0%] **-48.00dB] [off]
Front Right: Playback 0 [0%] -48.00dB] [off]
Simple mixer control ‘Speaker’,3
Front Left: Playback 64 [100%] [0.00dB] [on]
Front Right: Playback 64 [100%] [0.00dB] [on]
Simple mixer control ‘PCM’,0
Front Left: Playback 255 [100%] [0.00dB]
Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control ‘Center’,0
Mono: Playback 64 [100%] [0.00dB] [off]
Simple mixer control ‘LFE’,0
Mono: Playback 64 [100%] [0.00dB] [off]
Simple mixer control ‘IEC958’,0
Mono: Playback [off]
Simple mixer control ‘IEC958 Playback Source’,0
Items: ‘Digital Playback’ ‘Analog Mux 1’ ‘Analog Mux 2’ ‘Off’
Item0: 'Digital Playback’
Simple mixer control ‘IEC958 Playback Source’,1
Items: ‘Digital Playback’ ‘Analog Mux 1’ ‘Analog Mux 2’ ‘Off’
Item0: 'Digital Playback’
Simple mixer control ‘Swap Center/LFE’,0
Capabilities: pswitch pswitch-joined penum
Playback channels: Mono
Mono: Playback **[off]**Those items in red should be checked. I assume they are in that position because you believe you can not control them.

Why do you have digital playback selected, and then have IEC958 (which is the digital control) switched OFF ?

What is the name of the mixer application you are trying to use? kmix? alsamixer? Did you try the command line mixer program “amixer” ?

Why do you have so many alsa applications installed ? IMHO adding extra applications when you do not know what they will do is the windoze way, and in Linux it typically makes things worse and not better.

Do you have a copy of the /etc/modprobe.d/sound file from 11.0 ? You say it worked on the same hardware with 11.0 ? I am a bit surprised as your hardware audio codec is IDT 92HD73E1X5’ which is new and only recently supported well.

As noted before, the options you can force with this codec are:

STAC92HD73*
===========
  ref		Reference board
  no-jd		BIOS setup but without jack-detection
  intel		Intel DG45* mobos
  dell-m6-amic	Dell desktops/laptops with analog mics
  dell-m6-dmic	Dell desktops/laptops with digital mics
  dell-m6	Dell desktops/laptops with both type of mics
  dell-eq	Dell desktops/laptops
  alienware	Alienware M17x
  auto		BIOS setup (default)

Lets say you want to force the option “dell-m6”. Then you would do that by changing the /etc/modprobe.d/50-sound.conf file in 11.2 to:

options snd-hda-intel model=dell-m6
options snd slots=snd-hda-intel
# u1Nb.mu__efD1m12:82801JI (ICH10 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel

and save the change and restart alsa with su -c ‘rcalsasound restart’ and restart your mixer (kmix in kde and alsamixer in gnome) and then test your mixer control. Note this may make it worse ! No worried if it does.

If that is unsuccessful replace “dell-m6” with another code from the list I provided (such as “dell-eq” ) and restart alsa, restart your mixer and test. Do that for each option in the list.

Having typed the above, I am still not fully convinced your selecting digital playback may not be part of the cause of the problem.

ok… we’re getting nowhere here.

i’ve used kmix, alsamixer, but not amix. oddly, alsaconf will work against this hardware in 11.0, but does not here.

anyway if i knew the intricacies of alsa i would not be asking. i’ve never had a problem with alsa before, and i’ve used it a lot even successfully on this same machine.

i can tell you’re frustrated with me. i am frustrated too.

thanks for your help: i do appreciate your time. i’ll beat on it a bit more before i blow it off for another 64 bit dist.

do you ever sleep? :slight_smile:

best,
kenb

Did you try any of the model options by editing the /etc/modprobe.d/50-sound.conf file?

Reference your mixer, typically one uses different mixers on different desktops. Just what desktop are you using? KDE ? Gnome? something else?

amixer is rather cryptic to use, but one can learn more about it by typing:

man amixer

No, its not odd.

alsconf is depreciated and no longer used. Its out dated. It will create an /etc/modprobe.d/sound file, which is no longer used in openSUSE-11.2. Instead openSUSE-11.2 uses an /etc/modprobe.d/50-sound.conf file. If you run alsconf that will mess things up.

Instead one uses YaST > Hardware > Sound in openSUSE-11.2.

i’m using kde.

i have tried 2 of the options for the sound.conf file: intel, and no-jd. nothing changes. and i believe that no option defaults to auto. i can remove alsa rpms, as you suggested, or add them. no difference. i do use yast to configure the sound device, though there’s not a lot of configuring to do there. this is a home built system using an intel dp45sg board. i’ve put 11.2 on a separate drive from the 11.0.

the reason you saw all of the additional alsa rpms was because i removed all of the alsa packages, reinstalled them with the same result and then figured “what the heck?” and installed the others.

it could be this intel board. it has its quirks.

kenb

ok, then for KDE unless you have a better reason (such as you have activated pulse and are attempting to use it or you have a separate gnome desktop), I recommend you limit your alsa apps to what I have installed which is:

alsa-oss
alsa-utils
alsa-plugins
alsa-oss-32bit
alsa-plugins-32bit
alsa-devel
alsa-docs
alsa
libasound2
libpulse-mainloop-glib0
libpulse0
libxine1-pulse

plus the alsa-driver-kmp-desktop, because you are installing the cutting edge alsa apps.

You have so many pulse apps installed, and I have no idea what they do. Do you also have a gnome desktop installed for a different login, because that large number of pulse apps makes no sense to me.

I also recommend you test with more model options than just “intel” . I recommend you try each one. Be certain to restart alsa, or reboot after each (which will also restart alsa). The alsa developers, if they find motherboards of different manufacturers use the same model option setting, typically do NOT change the model name, nor add a new one. Hence even though it may say “dell-m6” it may work perfectly with an “intel” motherboard.

Now if, after all of our efforts (and there still may be some more things we can try) we fail, there is the option to write a bug report on openSUSE sound. The BIG advantage of this is it brings your sound problem to the attention the openSUSE packager for sound, who is also an alsa driver developer. He is very good at replying to bug reports and helping users fix sound problems. And any problem that he fixes will typically result in a fix to the driver, which is then sent upstream and benefits all Linux distributions.

I have had the same problem and I resolved it changing the volume using YAST…

goto YAST–>SOUND–>OTHERS–>VOLUME and set to 100 all channels (specially I note the mixer start to work normally when I set to 100 the “size” value)

Hope it helps…