Problem going graphical after logging in on Leap clean install


I’m a long time user of openSUSE. I decided this past weekend to install a clean version of Leap. I had been using openSUSE 13.2 with few problems.

After installing Leap and logging in, I get a corrupted desktop and the system is completely frozen. Can’t even change to another virtual console. Also CTRL-ALT-BACKSPACE multiple times doesn’t work. I realized that I had a similar issue in 13.2 and to resolve it, I installed the NVidia proprietary drivers and that resolved the issue for me in 13.2.

So using Yast in character mode, I added the NVidia repository and then did an online update followed by a reboot. Now, when I login, I do get different results. The system no longer hangs and after a long time, what looks like a proper desktop displays. However, I can move the pointer around but can’t select anything with the mouse or type anything. Also, after a few minutes minor corruption starts to occur on the desktop. I’ve tried the various desktop options offered at the login screen with similar results. Unlike with the native drivers, I can go to a virtual terminal and perform tasks in character mode even while this is occuring.

The video card involved is a very old NVidia 6150SE nForce 430. I’ve made no modifications to the boot instructions in Grub so everything should be default.

I’d be happy to provide logs or additional information. If I can’t resolve this, I’ll have to go back to 13.2 as I’m dependent on this system for a desktop.


Which NVIDIA driver flavour did you install?? I think that card requires G01 . not sure that is still supported???

Thanks so much for the reply. I used G02 which seems to be the correct one for that board. It was just released for 42.1 by NVidia in November so it’s also recent. I also used the 64 bit version which is the correct one for my version of Leap.

Anything else to check?

Hi - Solved!

Changing settings to use xrender rather than OpenGL resolved my issues.

I’m up and running using the full graphical environment in a Plasma desktop.

Thanks for the help.

Yes, G02 should be correct. That’s what I am using with a 6150LE card. And I have to use XRender for desktop effects. Otherwise it is unusable.

I’m glad you have it working.

Perhaps the card won’t support newer openGL version?

I do have an old laptop running oS 12.2 64-bit KDE 4.10.5 with a GeForce Go 6150.

“Composite Type” is set to OpenGL (no version number) and “Qt Graphics System” to rasterized.

Option “use OpenGL2 shaders” is ticked.

NVidia 3D driver is version 304.43 (from konqueror’s sysinfo:/), packages are G02.

Yes, the 6150LE works fine with nvidia drivers on KDE4 – configured to use OpenGL 2. But it doesn’t work with Plasma 5.

NVidia 3D driver is version 304.43 (from konqueror’s sysinfo:/), packages are G02.

That (304.43) is old. I have a copy of 304.128, but I think it is up to 304.131 (or something similar).