Problem going graphical after logging in on Leap clean install with older NVidia card

Hi,

I originally posted this in the Applications forum but I’m reposting it in this forum as I do think it’s a hardware/driver issue.

I’m a long time user of openSUSE and have used this current hardware exactly the same for years on various versions of openSUSE.

I decided this past weekend to install a clean version of Leap. I had been using openSUSE 13.2 with few problems.

After installing Leap and logging in, I get a corrupted desktop and the system is completely frozen. Can’t even change to another virtual console. Also CTRL-ALT-BACKSPACE multiple times doesn’t work. I realized that I had a similar issue in 13.2 and to resolve it, I installed the NVidia proprietary drivers and that resolved the issue for me in 13.2.

So using Yast in character mode, I added the NVidia repository and then did an online update followed by a reboot. Now, when I login, I do get different results. The system no longer hangs and after a long time, what looks like a proper desktop displays. However, I can move the pointer around but can’t select anything with the mouse or type anything. Also, after a few minutes minor corruption starts to occur on the desktop. I’ve tried the various desktop options offered at the login screen with similar results. Unlike with the native drivers, I can go to a virtual terminal and perform tasks in character mode even while this is occuring.

The video card involved is a very old NVidia 6150SE nForce 430. I’ve made no modifications to the boot instructions in Grub so everything should be default and as noted the same hardware worked fine on 13.2.

I used G02 which seems to be the correct one for that board. It was just released for 42.1 by NVidia in November so it’s also recent. I also used the 64 bit version which is the correct one for my version of Leap.

Anything else to check?

I’d be happy to provide logs or additional information. If I can’t resolve this, I’ll have to go back to 13.2 as I’m dependent on this system for a desktop.

Thanks.

What DE did you installed?
What happens if you login to iceWM?

Hi,

Thanks for responding.

Not sure what you mean by DE? If you mean distribution, it’s Leap 42.1 It was a clean install taking all defaults. I added the NVidia proprietary driver as noted in my original thread after install time.

Regarding iceWM, I’ve discovered that it does work. I’m actually writing this now to you using Firefox under iceWM. So, it seems that the issue is with KDE/Plasma possibly interacting with my graphics card/driver or something totally different?

Let me know if I can provide any additional information.

Hey, not to disturb, but I have the same problem but with a 7200GS/7300LE and the G02 driver, so seems to be an issue with the driver.

Installed the 304.131 the hard way (the current version in the Leap repository is 304.128) and the issue persists.

So far Openbox and IceWM work for me, however Plasma 5, GNOME or Cinnamon crash/freeze instantly.

Could you check with

journalctl -k

and see if your have any NVMR Xid error? (so far I have 13,9 and 1)
http://docs.nvidia.com/deploy/xid-errors/index.html

DE is Desktop Environment. In openSUSE you could be running any of a number of different DE’s

Default is KDE plasma5

Hi,
I am not using plasma5 but I tested it for a short time and seen what you are experiencing at present.
I am using nvidia graphic card and I always install the .run proprietary driver from nvidia.
You can try this procedure:
Login to iceWM, open a terminal and run

systemsettings5

after that go to display and you can choose to disable the desktop effects or if you want to experiment with desktop effect replace opengl with xrender. Logout and login to plasma5. When logging in to plasma 5 because of the changes I observe that it will take sometime on my machine to reach the gui of plasma 5.
When you get to the gui of plasma 5 and still it is freezing logout again and login to iceWM and in systemsettings 5 find in the options because I can’t recall it on top of my mind the exact settings to disable kscreen2, when you find it disable it and logout and login to plasma 5 again and see if it will function properly. hope this helps.

The one I pointed to you was what I did on my machine and is not guaranteed to work on yours, but there is no harm in trying.
Oh, I notice also on my side that disabling kscreen2 I never had freezing using opengl. I always rely on nvidia-settings to adjust my display settings.

Thanks for the suggestions. I will try them tonight.

Regarding Xid errors, I do not see any.

I will report back on my findings after experimenting.

Forgot to mention the Xid errors happen when you start Plasma 5.

Good luck :slight_smile:

OK. Temporarily, solved!

FIrst off, yes, I was getting Xid errors. 8, 9 and 13.

I tried turning off desktop effects. No difference.

What did work is I changed the settings to use xrender rather than OpenGL. That immediately worked. I could turn all effects back on and login to Plasma desktop and everything works fine. I no longer get Xid errors either.

Perhaps I’m paying a performance penalty for not using OpenGL and if true, I’d still like this resolved. But in the meantime, it’s working!

I have three choices when I try to login:

  • iceWM
  • KDE Plasma Workspace
  • Plasma 5

I presume the two Plasma entries are actually the same thing? Can you confirm?

Also, would you suggest i log an issue with openSUSE on this so that perhaps at least it can be documented in the release notes as a known issue even if it’s really an NVidia issue?

You did not mention regarding disabling kscreen2 and reverting back to opengl if it will work.
Good to know that you can now use plasma5.

I think those 2 kde choices are the same.
The iceWM is included in the install and a good one
to have an alternative in case there is a problem just what had happened to you.

I wasn’t sure how to disable kscreen2. If you can give me instructions, I will try it and let you know.

What I’m also wondering now is if I disabled OpenGL if the original nouveau driver would work as well and I wound’t even need the NVidia Proprietary driver? Care to wager?

Hi,
This prompted me to add plasma 5 on my 7 year old laptop, an x_64 amd athlon x2 with 4GB ram and nvidia 8200M G graphic card.
I am using the legacy graphic driver from nvidia site( NVIDIA-Linux-x86_64-304.131)
I can confirm here that opengl 3 is working with no freezing with compositor is enabled. The speed of the compositor has to be set to 50%.
kscreen2 is also disabled.

To disable kscreen2 it is under systemsettings5 (configure desktop)-startup and shutdown-background services-startup services.

What I’m also wondering now is if I disabled OpenGL if the original nouveau driver would work as well and I wound’t even need the NVidia Proprietary driver? Care to wager?

I can’t answer you with that, but In this laptop using nouveau, I cant play video in you tube as an example in full screen, it slow the video, while with nvidia driver video works properly.
I am writing this post in plasma 5.:slight_smile:

I like to add also that I choose not to use plasma 5 in this laptop because it tends to overheat.
I am using enlightenment here on a daily basis for my wife’s surfing and watching web videos.:slight_smile:

To close out this thread, I have tested now disabling kscreen2 and no difference. With kscreen2 disabled and as soon as I select OpenGL, the desktop hangs right there.

So kscreen2 seems to make no difference.

I’m happy with my solution for now.

Thanks to everyone for helping.

I can get back to work now!