Problem Dual-booting with Kubuntu 9.04

Hi. I’ve just installed openSUSE on my system, and am having a problem with my dual booting - I have another partition on my system with Kubuntu 9.04 on it, but I do not have an option for this - only for openSUSE 11.2 and openSUSE 11.2 failsafe.

The partition is there, and I can see it in dolphin - though unfortunately I can’t seem to do anything with it. (My kubuntu is ext4, and I don’t think my ext3 openSUSE can read it, from what I know?)

Anyone know how I can fix my problem?

open a terminal, go su and do the following:

fdisk -l

post result

we’ll need the current


fdisk gives me ‘command not found’.


 Modified by YaST2. Last modification on Sat May  2 00:24:37 BST 2009
default 0
timeout 8
##YaST - generic_mbr
gfxmenu (hd0,1)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.1 -
    root (hd0,1)
    kernel /boot/vmlinuz- root=/dev/disk/by-id/ata-TOSHIBA_MK1652GSX_78OVFCZ6S-part2 resume=/dev/disk/by-id/ata-TOSHIBA_MK1652GSX_78OVFCZ6S-part6 splash=silent showopts vga=0x317
    initrd /boot/initrd-

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 11.1 -
    root (hd0,1)
    kernel /boot/vmlinuz- root=/dev/disk/by-id/ata-TOSHIBA_MK1652GSX_78OVFCZ6S-part2 showopts ide=nodma apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x317
    initrd /boot/initrd-


/dev/disk/by-id/ata-TOSHIBA_MK1652GSX_78OVFCZ6S-part1 swap                 swap      defaults              0 0
/dev/disk/by-id/ata-TOSHIBA_MK1652GSX_78OVFCZ6S-part6 swap                 swap      defaults              0 0
/dev/disk/by-id/ata-TOSHIBA_MK1652GSX_78OVFCZ6S-part2 /                    ext3      acl,user_xattr        1 1
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0

Command not found implies you didn’t use su first…

But I really don’t think this will help, I’ll point you to this as the Suse wiki has no info on ext4…

Ext4 - ArchWiki

Now you’ll notice 2 things first is a kernel greater than 2.28 I doubt 11.1 is running it. That will enable you to mount it as long as the kernel config is correct. Next you’ll notice you need a patched grub.

I’m not aware of a specific suse tut. I suspect it is possible but as you missed the su in the post highly unlikely to be easier enough for you.

While it will be a problem using the SUSE bootloader to run Kubuntu if Kubuntu’s boot partition is EXT4, surely there’s no problem using the Kubuntu bootloader to boot SUSE?

I’d just stick a Kubuntu CD in the drive, try to repair the installation (replace bootloader), then ask either here or on a *buntu forum how to put a boot stanza in its Grub menu for SUSE.

Are you using the OpenSUSE 11.2 milestone, or the 11.1 release?

No idea if the grub that comes with 11.2 have been patched with ext4 support, but the one in 11.1 is not. You will need to switch to the grub included in Kubuntu if you want to boot to it. Even with the correct config, if grub do not support the filesystem, it will not boot.

The easier way will be to reinstall Kubuntu, and at the grub install phase, select to install (or replace) the one already in the MBR. If you dont want to reinstall it again, the steps below can give you a guide (but can break both installations btw).

The alternate (and long method) - again not recommended. Dealing with a HD boot sector can make the whole HD unbootable. The steps assume the disk is sda, replace it with your current disk assignment.
[li]Get your partition UUID number by typing [/li]```
ls -l /dev/disk/by-uuid/

[li]Boot with the Kubuntu CD, then mount the Kubuntu partition and check the contents of the /boot directory.[/li]```
mkdir /mnt/kubuntuhd
mount -t ext4 /dev/sda# /mnt/kubuntuhd
ls -l /mnt/kubuntuhd/boot/

[li]Mount your suse partition[/li]```
mkdir /mnt/suse
mount -t ext3 /dev/sda# /mnt/suse

[li]From that Kubuntu CD, edit your SUSE grub menu.  You can make a copy of the SUSE entry and replace the image and root= entries with the image name and UUID you got previously.
[/li][li]Now as root, chroot to your Kubuntu installed partition (check Internet on how to chroot to another installed system) and issue a grub-install /dev/sda. You can try that directly from the CD without chrooting, but if the grub revision on the installed disk is different from the CD, grub will fail to show at all.

Good luck and hope that helps

Ubuntu does that on its own (unfortunately!) unless explictely told not to.

Another solution would be to install grub from Ubuntu in your (Ubuntu) root partition and add an entry in your /boot/grub/menu.lst in openSUSE to call Ubuntu grub bootmenu, then boot Ubuntu from there. You will boot Ubuntu in two steps instead of one.

Assuming (just an example), your Ubuntu root partition is sda6 in Linux, which is equivalent to (hd0,5) in grub ( -1 ), in openSUSE, you would add the following at the end of /boot/grub/menu.lst :

title Ubuntu Grub
root (hd0,5)
chainloader +1

Then, boot Ubuntu however you can (with Ubuntu live CD for example) and type in a terminal :

# sudo grub
root (hd0,5)
setup (hd0,5)

Then you should be able to call Ubuntu bootmenu from the openSUSE bootmenu and boot your ext4 partition from that grub. You don't need to reinstall an OS for that. But next time you do, format your root partition in ext3 ant the rest in ext4 if you like.

* !!! Replace (hd0,5) with the Ubuntu root partition on your computer !!!