Problem: dual boot WIndows 8.1 / openSUSE13.2

Hello out there: I would appreciate some assistance with the following :

I will try to explain in detail here - I am having trouble getting my dual boot machine to work (openSUSE 13.2 / WIndows 8.1 )
My machine is several years old ( BIOS/MBR ) and all of that. I have installed two - 1 Terrabyte hard drives on this machine ( its a 32 bit PC )
I had successfully installed openSUSE on 1 hard drive (/dev/sda ) and my plan was to install Windows 8.1 on the other(/dev/sdb) -

I had some difficulty getting WIndows to install - I finally physically unhooked my Linux drive in order to get Windows to install ( and it did )

Previous incarnations of WIndows - like WIndows 7 Professional - allowed me to use the following procedure.

(A) install Windows on 1 drive - then re-install Linux on the other drive - GRUB2 was smart enough to build a new MBR and then supply me with a nice

little menu - asking whether you would like to boot to Linux or would you like to boot to Windows ?

(B) I tried the same procedure here - Installed and tested Linux 13.2 on 1 drive - then the idea was to install Windows 8.1 professional on the other drive
then re-install Linux - which was smart enough to give me both systems - This linux install appeared to proceed normally - everything seemed OK - and
yes I plugged the linux drive back in BEFORE I tried to install linux! The linux drive was partitioned as follows

    (/dev/sda1)     2  GiB           swap
    (/dev/sda2)     20 GiB           /
     (/dev/sda3)    950 GiB         /home           ( the rest of the disk - approximately 950 gigs )

I am not certain how the WIndows drive is partitioned - The install did any partitioning required -

(C) Now after installing Linux and booting up the PC BOOTS UP TO Windows ???

I am at a total loss and would appreciate any assistance you may offer.

Regards Leland Muri

Depends on which drive is the boot drive. The way you installed each would have a mbr so just change the order of boot there should be a boot flag on the root partition for Linux and the boot partition for Windows… Note that you do not have to reinstall Linux just boot it then in yast force a change in Yast -boot manager (Be sure the scan for other OS box is checked) and it should pick up Windows.

I am having a problem setting up a Dual boot under Windows 7 Ultimate: Windows is installed in sda1 and sda2, Linux was installed under sda3, 4,5,6 with swap. The program for boot loader is load into MBR and Scan for other OS checked. The Linux OS goes into a rescue mode. What am I missing? Should the Linux be loaded into an Extended Partition? or into sdc. Sdb is a terabytye external hard drive on USB.

You have a different problem and should start your own thread

Quick guess a video driver problem.
If it is not installed in an extended ( by the numbers you say) then you are using GPT structured drive and there is no such thing as an extended partition. So again guessing this is an EFI BIOS machine and you may have mixed MBR and EFI booting which is sure to produce major headache. Again not the original posters problem so start a new thread