Problem Debugging with KDevelop


I am just starting with KDevelop 3.5.1.
I created a simple HelloWorld application

int main(int argc, char *argv])
cout << “Hello, world!” << endl;

I was able to execute my program from KDevelop IDE via F9.
However when I set a breakpoint on the 1st executable line and try to run the debugger, it crashes with the following error displayed in the pop-up window:

“GDB Exited abnormally. This is likely a bug in GDB…”

The GDB pane displays the following:

gdb /home/Source/HelloWorld/debug/./src/helloworld --interpreter=mi2 -quiet
Using host libthread_db library “/lib/”.
(gdb) Process exited

Any thoughts or insights would be appreciated



did you compile your program with debug informations ("-g" option), otherwise the debugger won’t work correct.

Hope this helps

I sort of suspected that.
How do I turn on the debug information for my KDevelop project?
Do I have to edit one of the make rules in the Makefile or there are some KDevelop settings that can be changed?

Thanks /Danke


this depends on your project if it is automake or qmake you have to switch debug on in the automake/qmake manager. If you are using custom make files you have to add the compiler flags for debug direct in the make file.

Hope this helps

I was able to step through my code after I added -g option to both CFLAGS and CXXFLAGS in my Makefile.
Thanks to everyone who replied!

Same issue here… It helped me also! Thanks guys.

Thanks a lot. This helped me too.