Problem copying music files from USB drive to HDD

I’m trying to copy my music library from my Fat32 formatted USB external drive temporarily to an internal NTFS formatted HDD. My intention is then to reformat the USB drive to ext4 and copy it all back to the USB drive.

The problem I’m having is that some files refuse to copy as they have apostrophes in the filename, e.g. Don’t answer me.flac. I get a message saying that the file does not exist. Any suggestions how I can get around this?

Incase you’re wondering, the reason why I’m copying to an ntfs drive is that it’s the only one with enough space on it. Now that I’ve put oS11.2 on what was my XP box I’m working on formatting all my drives to ext4 but it requires some juggling around with copying stuff backwards and forwards :rolleyes:

If there are not many of such, you could rename the file/s:
a.flac
b.flac
c.flac

I tried that but I get a message saying the file does not exist. When viewing the file in Dolphin or in the terminal the apostrophes is replaced with a ?

Message when I try rename the file in dolphin

http://i198.photobucket.com/albums/aa111/sklipikish/openSUSE/th_snapshot30.png](http://i198.photobucket.com/albums/aa111/sklipikish/openSUSE/snapshot30.png)

Tried renaming in the terminal but couldn’t get it to work. I tried escaping the spaces with \040 or putting the file name in " " but wouldn’t work.

I’ve come across this before somewhere but I can’t get my little grey cells working. I’ll check around, but someone else may get you the solution before I do.

What were you doing in the terminal?
mv /path_to_file/filename newname

Actually I tried using the copy command.
cp /path/to/filename /path/to/new_filename. Tried is as su.

mv is to rename

I resolved this. I discovered I was only seeing the problem when I was administer the boc remotely through vnc remote desktop. If I logged directly onto the PC there is not trouble with the file names. They copied over no problem with the apostrophes and special characters.

It seems either my laptop (the remote client) or vcn didn’t like the special characters. I suspect it was vnc but will check when I have some time.

Yes, I get than over ssh too.
I didn’t realize - sorry.