Problem connecting to source of software

I just installed Opensuse 13.1 KDE from a pen drive and due to some odd reason while installing applications or their dependencies I get these errors in all package managers including CLI zypper. I have read other threads with similar problems but so far none are like this.

This is the destination I am getting

hd:///?device=/dev/disk/by-id/scsi-1SanDisk_Cruzer_Blade_4C530599900418100000-part2

That is not a URL

Here are snaps when using apper, yast or zypper. I tried refreshing repos some don’t get refreshed.

For Yast
http://i1150.photobucket.com/albums/o605/Mavs201/problem_zps5d797556.jpeg

For apper http://i1150.photobucket.com/albums/o605/Mavs201/problem2_zps740c5feb.jpeg

And for Zypper

http://i1150.photobucket.com/albums/o605/Mavs201/problem1_zps4ab926e7.jpeg

I can’t check for updates. Same error as above.

This is the USB stick (?) you installed openSUSE from.
It is still configured as active installation source.

Either re-insert that stick, or remove/disable it in YaST->Software Repositories.

Well it half worked. I did remove from Yast but when the installation process finishes I still can’t find chrome. I just performed an update so now I’ll download again and get back to you.

Found it. Did not show up in search but shows up in app type or genre.
In application > system.

Thank you problem solved.