Problem Connecting to Internet

Hello there, I’m new in linux…and I have some problems now with the internet connection.

I connect my acer aspire 5100 with opensuse 11.2 to my home router. with manual configurations.

In the router I can see the laptop in attached devices, and in laptop I can ping my router and my other computer. But I don’t have connection to internet and is not a problem of DNS because I can’t ping the Ip of the google to. :
any one can help me?

Make sure the gateway IP address and the IP addresses of the Name Servers provided by your ISP are coded into the settings

In gateway and dns server I had put my router IP. Because the router have the default configurations of my ISP.

Try adding name servers (IP addresses) explicitly in DNS server rather than gateway in DNS server

I don’t know if this help, but…

Kernel Ip routing table
Gateway *
Iface wlan0

I don’t knowcorrec if I’am t…but this means that I don’t have my default gateway configured. Right? but on KDE Network manager I have my router address…

And many thanks swerdna for the quick help…

When that is all and everything that your route statment is saying you definitely have no access outside your LAN. There should be a default route. Look at mine:

henk@boven:~> /sbin/route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface        *        U     0      0        0 eth0
link-local      *          U     0      0        0 eth0
loopback        *            U     0      0        0 lo
default         adsl.henm.xs4al         UG    0      0        0 eth0

(and please also see how I put computer output between CODE tags, when done this will retain the layout the system produced).

This default route either should be set by DHCP when you use it, or you must set it yourself (in YaST > Net work devices and then tab Routing).

Thank you very much…and sorry about the computer outputs without CODE tags…but like I said I’m a new one here.

I went to YaST, and in routing tab only the scroll to choose a device is unlock…all the rest are block! I can’t write anything in there…what I have to do to add a default gateway on the routing table…

In your first post you said you did “with manual configurations”. How and where did you do that manual configuration for your network?

try turning off IPv6 (if it does not help it is easy to undo), see:

if it works we/someone can tell you how to make it persist over boots…


You said the devices are locked. Probably locked for editing in Yast because you have settings for control by network manager.

In Yast you have to switch to “traditional method with ifup” as in pic 2 of this tutorial: HowTo Configure a network card in Suse/openSUSE 10, 11 for LAN and Internet Access.