Problem connecting a printer

I hope this is in the right area.

I am trying to connect a HP Printsmart Premium c309g printer using a wireless connection.

I have configured it and it operates correctly on a laptop running Windows 7.
I have installed it and it operates correctly using a USB connection on this computer running 12.1
I have added it and it operates correctly as a cups printer using a wireless connection.
I cannot get it to install using hplip. The process ends saying it cannot see the printer and the ip address is all zeros.

At this point, I have uninstalled hplip version 3.11 that is in the opensuse repositories and have tried to install hplip version 3.12 from the opensource area of HP’s web site. The installation stops with a message that it cannot find the file libusb. Using yast I can see that libusb-0_1-4 and libusb-1_0-0 are both installed.

So I downloaded the source tar ball and attempted to do a manual install. I hit the same error about libusb.

For me, best case would be to figure out where the problem is doing this manual installation and have it work.
Next best would be to be able to install the downloaded version and have it work.
Completely acceptable would be to reinstall hplip 3.11 and get the printer to work.

Is anyone using a HP multi function printer, wirelessly, on 12.1 without problems?

I suspect that this may be a well-known problem; you need to set a static IP for both Windows and Linux using the HP’s browser interface. This will normally disconnect the connection as you won’t have set the same IP as your browser is using. But, with a couple of restarts, you should be able to get everything working.

I would start by setting the IP in Windows and, when you are sure that is working, go into YaST to complete the set-up. As long as you have hplip installed before you go into YaST, I don’t think you will have any problems.