Problem configuring external monitor speakers, please assist

I am new to openSuse and the KDE desktop. Just installed the OS and have difficulties to get the sound configured to where it plays on the built-in speakers of the external monitor instead of playing on the internal laptop speakers.
I have a Thinkpad X230 connected over an displayport cable to an external monitor with build in speakers. When I play music it uses the laptop speakers instead of those of the monitor.
I went to “configure the desktop”, - hardware - multimedia - audiocd Slave configuration. I then selected “Phonon”. Under the tab “Device preference” I can see 2 audio playback devices. One says “built-in Audio Analog Stereo” (the laptop) and the second “LT2323z Analog Stereo” (the ext. Monitor)
I choose the monitor as preference, hit the "test button below, sound comes out of the monitor as I want, I hit “apply”
The second tab which is “Audio hardware setup” then automatically shows the monitor and allows me to change the profile and connector should I so wish. Here you can test the left and right speaker, and when I try those the sound now comes out of the laptop instead.
.I have tried changing the settings to use both the playback devices, and changed to the various profile and sound device settings on offer but I cannot get the sound to play on the ext. monitor speakers when looking at a movie or playing music.
I am now at my wits end and could really need some help please.

For sound configuration, please look here: PulseAudio and Selecting the Proper Sound Card Configuration - Blogs - openSUSE Forums

In KDE, you set your monitor in Menu / Configure Desktop / Hardware / Display and Monitor / Size & Orientation (on left).

See if this info helps …

Thank You,