Problem compiling xf86-video-intel-2.17.0 on openSUSE 11.4

I’m trying to compile xf86-video-intel-2.17.0 on openSUSE 11.4 (can’t upgrade to 12.1; the laptop can’t boot from the USB image :frowning: ) but I get this error:

intel_dri.c: In function ‘I830DRI2CreateBuffer’:
intel_dri.c:343:9: error: ‘DRI2BufferHiz’ undeclared (first use in this function)

I can compile xf86-video-intel-2.15.0 but nothing else because of DRI issues. Either configure can’t find DRI2 or the final result doesn’t compile.

Any ideas?

Try following these directions, it worked really well for me:

Ladislav’s blog: Installing latest Intel graphics driver to openSUSE 11.4

btw: substitute 2.15 with 2.17 the procedure is still the same.


I’m getting exactly the same error when i make on OpenSUSE 11.4, no errors at the configure stage. I dont even need the i830 driver but I’ve got no idea how to remove it. If anyone can help with the configure options to not compile the i830 driver i would appreciate it

Why are you trying to compile on your own? Any reason for doing so?

The reason is that the latest (as I write) Intel video driver 2.17.0 has better support for Sandy Bridge core i3/i5/i7 integrated graphics. AKA “Core family integrated graphics controller” and “Intel HD graphics”. The release notes have all the details:

Intel Linux Graphics: 2011Q4

This driver is not currently available from any OpenSUSE repos and because my client had stability problems on OpenSUSE 11.4 x64 on a Core i3 it was essential to get this compiled and installed

I confess that would be my question also. It can be difficult to compile video drivers such as the Intel driver.

If it were me, I would search for an update to the xorg-x11-driver-video rpm (which contains the intel driver) on Search Results for xorg-x11-driver-video on openSUSE-11.4 … now one is likely to get many hits with openSUSE-11.4 and the idea is to find an rpm with the 2.17.0 already packaged. For example, take a look at this repository of jobermayr which has xorg-x11-driver-video-7.6.99.git20120119.1957-1.1.x86_64.rpm . I would download the src file xorg-x11-driver-video-7.6.99.git20120119.1957-1.1.src.rpm and then copy that file in its own directory and then open that file with the rpm2cpio command:

rpm2cpio xorg-x11-driver-video-7.6.99.git20120119.1957-1.1.src.rpm | cpio -idmv

and then look inside the file xf86-video-intel.tar.bz2 , looking at the “NEWS” file which may have something like:

Release 2.17.0 (2011-11-16)
A few months have passed, and we have accumulated a surprising number of
bug fixes. Oops! We would strongly encourage everyone to upgrade.

and hence one can see that likely the xorg-x11-driver-video-7.6.99.git20120119.1957-1.1.x86_64.rpm has the 2.17.0 driver.

Now to update to that is a different story, as there could be dependencies and other risks that I do not know enough about to advise, but one could investigate such a course of action and assess the risks.

What openSUSE repos do you refer to ? You stated ‘any’ but I assume you exaggerate and don’t really mean ‘any’. See my above post.

I downloaded the source from the intel linux graphics site, compiled and installed. Xorg.0.log shows 2.17.0 loaded and its all good with the kernel i updated to in software update so happy days. I’ll post the procedure a bit later just heading out to recover a windows server haha.

This procedure is a howto install the latest Intel display driver (2.17 at this time), from source on a machine running OpenSUSE 11.4


If you have a Sandy Bridge Core i3/i5/i7 and you are using the onboard graphics, AKA “Core family integrated graphics controller”, “Intel HD graphics” this driver is recommended because of stability fixes. I don’t know if there are any benefits for other CPU/GPU combos but this driver solved my problem of server randomly hanging/crashing after intensive use.


  1. In this case, I started with a fully updated 64-bit OpenSUSE 11.4 (Gnome) installation running Kernel
  2. The amount of shared memory was fixed to 256Mb in the BIOS
  3. Check /var/log/Xorg.0.log for the version number of module (2.14.0 in my case)

Read through this procedure for installing version 2.15 but do not do it straight away because there are dependencies and build requirements to install first.

Ladislav’s blog: Installing latest Intel graphics driver to openSUSE 11.4

  1. Install the following packages through YaST Software Management:

autoconf, automake, xorg-x11-server-sdk, xorg-x11-proto-devel, gcc

  1. Download the following source archives to your Downloads directory:

Intel 2.17 driver here: Intel Linux Graphics: 2011Q4 then click on xf86-video-intel 2.17.0 release to download

DRI2 protocol headers 2.6 here: xorg/proto/dri2proto - DRI2 Protocol Headers. then click on dri2proto-2.6.tar.gz macros 1.16.1 here: xorg/util/macros - macros utilities. then click on util-macros-1.16.1.tar.gz

and you are good to go


  1. In your Downloads directory:

tar zxvf util-macros-1.16.1.tar.gz
cd util-macros-1.16.1
make install

this installs: xorg-macros.m4 to /usr/local/share/aclocal
xorg-macros.pc to /usr/local/share/pkgconfig
INSTALL to /usr/local/share/util-macros

(check that they are there!) then,

cd /usr/local
chmod a+w share

cd to your Downloads directory

  1. Add all of the dirs in step 1 to the PKG_CONFIG_PATH


  1. In your Downloads directory:

tar zxvf dri2proto-2.6.tar.gz
cd dri2proto-2.6
make install
cd …

  1. These instructions for compiling the actual driver I modified from those on Ladislav’s blog I mentioned in a previous post

tar xfjv xf86-video-intel-2.17.0.tar.bz2
cd xf86-video-intel-2.17.0

now open your favorite text editor and load ./src/intel_dri.c for editing
if using a graphical editor browse to Home/Downloads/xf86-video-intel-2.17.0/src and open intel_dri.c

Scroll down to line 343 and delete it and the next 4 lines:

case DRI2BufferHiz:
if (SUPPORTS_YTILING(intel)) {

^^^^^^^ all of that, delete it!

Delete any blank lines you made in the code and save the file

Back in the xf86-video-intel-2.17.0 directory:

./configure --prefix=/usr --libdir=/usr/lib64
make install

Open YaST, look in the System section and click on Boot Loader
Make sure Desktop is highlighted, click Edit
In the Section Settings, in the box called “Optional Kernel Command Line Parameter”, type a single space after the last entry then


and click OK and OK again

and you are done. Restart your computer.
Check /var/log/Xorg.0.log for the module version of (now 2.17.0)
success!! oh what happy days!!