problem booting from grub2 prompt after kernel update


after a recent kernel update the usual grub2 boot menu doesn’t show up; instead I get the grub prompt


I used the tutorial in
with the commands

grub> set root=(hd2,3)
grub> linux /boot/vmlinuz-XXXX root=???
grub> initrd /boot/initrd.img-XXXX
grub> boot

to reboot my computer, with XXXX replaced with one of the kernels I found, but it seems to fail because I do not know the device name I should use instead of ??? (I have several hard drives; the system drive is a solid state drive). I tried “/dev/sdc3” and “/dev/nvme0n1p3” but it didn’t work. Is there any way to see the actual device names before I boot the machine? E.g. in the BIOS or what-do-I-know?

Thanks for any help!

P.S. To clarify, the boot process starts, but gets stuck in an seemingly infinite waiting loop “A start job is running for dev-???.device”

How are you booting?

In particular, do you have two or more linux systems installed? If you do, then you might be using the boot menu from a different linux install that does not know about your kernel update. In that case, you need to boot that system, and update grub there.

There was also a recent update to grub2. It is possible that your problem is due to that update.

At this stage, it’s a bit difficult to know what has broken. And additional information might help.

P.S. To clarify, the boot process starts, but gets stuck in an seemingly infinite waiting loop “A start job is running for dev-???.device”

When you boot with a manually entered grub command, that can lead to such problems if you got the command wrong.

There’s a super grub disk that you might be able to download, that can supposedly help deal with these situations.

you can boot the Rescue System from your installation media or download a LIVE system like

then commands like

# parted -l



will give you information about your setup. You can chroot into your system and update GRUB.

For a more detailed advice it would be good to know:

Are you BIOS or UEFI booting?
What OS do you have installed (openSUSE Leap 15.1, openSUSETumbleweed, …)?




thanks for your replies! I have (only) opensuse Leap 15.1 installed.

I think I am UEFI booting (however I’m not exactly sure what the difference between BIOS and UEFI booting is).

The next thing I will try is to boot a live opensuse USB stick and try to fix the boot loader. (I might be back with more questions if google doesn’t give me enough information…)

This might take a while, since the machine is located in my office which I currently can’t access easily.

Thanks again!


update – I solved my problem! It was actually easier than thought; I just skipped the root=??? option in the linux command when booting from the grub prompt, and it was apparently not needed. The system was booting fine, and I rewrote the bootloader configuration files with yast.