Probleem met snelle geheugenkaartjes

Hallo,

Sinds een tijdje heb ik steeds problemen met de rechten van enkele van mijn fotokaartjes. Om één of andere reden staan ze “alleen lezen”.
De fototoestellen (beide Nikon) kunnen ze wel gewoon gebruiken en formatteren, maar dan kan ik nog niets ermee in mijn pc.
Het gaat om snelle kaartjes Ultima Pro van 4 en 8GB.
Iemand een idee wat ik hieraan kan doen?

Besturingssysteem is openSUSE 12.1 64 bit met Gnome 3

Kun je 's zo’n ding aankoppelen, en meteen daarna de output posten van


dmesg
mount

en die hier kopiëren tussen CODE tags (de # in de editor) ?

Begrijp ik je goed, en kon je ze eerst wel volledig benutten?

Ja, kaartjes waren vroeger gewoon te beschrijven in de pc. Wij wisselden dikwijls bestanden uit met de kaartjes. Hij heeft een andere pc met Ubuntu, maar gebruikt wel een gelijkaardige usb kaartlezer als ik, een Integral met 6 ingangen.
Hier volgt de output van dmesg mount (is wel een enorme lap tekst waar je het begin zelfs niet meer ziet, USB zaken staan ergens middenin):

oeps, krijg van het forum dit te zien:

The text that you have entered is too long (29454 characters). Please shorten it to 15000 characters long.

Ik kort de tekst dus maar in tot bij de USB meldingen, hopelijk doe ik niet de verkeerde regels weg.

    0.217484] pnp 00:06: [io  0x0778-0x077f]

    1.282106] ehci_hcd 0000:00:02.1: new USB bus registered, assigned bus number 1
    1.282420] ehci_hcd 0000:00:02.1: debug port 1
    1.282579] ehci_hcd 0000:00:02.1: cache line size of 64 is not supported
    1.282604] ehci_hcd 0000:00:02.1: irq 23, io mem 0xdfefec00
    1.288026] ehci_hcd 0000:00:02.1: USB 2.0 started, EHCI 1.00
    1.288211] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
    1.288369] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
    1.288650] usb usb1: Product: EHCI Host Controller
    1.288808] usb usb1: Manufacturer: Linux 3.1.10-1.16-desktop ehci_hcd
    1.288964] usb usb1: SerialNumber: 0000:00:02.1
    1.289290] hub 1-0:1.0: USB hub found
    1.289447] hub 1-0:1.0: 10 ports detected
    1.289710] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
    1.290127] ACPI: PCI Interrupt Link [LUB0] enabled at IRQ 22
    1.290297] ohci_hcd 0000:00:02.0: PCI INT A -> Link[LUB0] -> GSI 22 (level, low) -> IRQ 22
    1.290596] ohci_hcd 0000:00:02.0: setting latency timer to 64
    1.290598] ohci_hcd 0000:00:02.0: OHCI Host Controller
    1.290764] ohci_hcd 0000:00:02.0: new USB bus registered, assigned bus number 2
    1.291103] ohci_hcd 0000:00:02.0: irq 22, io mem 0xdfeff000
    1.344043] usb usb2: New USB device found, idVendor=1d6b, idProduct=0001
    1.344202] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
    1.344485] usb usb2: Product: OHCI Host Controller
    1.344639] usb usb2: Manufacturer: Linux 3.1.10-1.16-desktop ohci_hcd
    1.344796] usb usb2: SerialNumber: 0000:00:02.0
    1.345080] hub 2-0:1.0: USB hub found
    1.345235] hub 2-0:1.0: 10 ports detected
    1.345475] uhci_hcd: USB Universal Host Controller Interface driver
    1.345667] Initializing USB Mass Storage driver...
    1.345851] usbcore: registered new interface driver usb-storage
    1.346036] USB Mass Storage support registered.
    1.346200] usbcore: registered new interface driver ums-alauda
    1.346368] usbcore: registered new interface driver ums-cypress
    1.346536] usbcore: registered new interface driver ums-datafab
    1.346702] usbcore: registered new interface driver ums-freecom
    1.346868] usbcore: registered new interface driver ums-isd200
    1.347049] usbcore: registered new interface driver ums-jumpshot
    1.347214] usbcore: registered new interface driver ums-karma
    1.347380] usbcore: registered new interface driver ums-onetouch
    1.347545] usbcore: registered new interface driver ums-sddr09
    1.347711] usbcore: registered new interface driver ums-sddr55
    1.347878] usbcore: registered new interface driver ums-usbat
    1.348093] i8042: PNP: PS/2 Controller [PNP0303:PS2K] at 0x60,0x64 irq 1
    1.348251] i8042: PNP: PS/2 appears to have AUX port disabled, if this is incorrect please boot with i8042.nopnp
    1.349237] serio: i8042 KBD port at 0x60,0x64 irq 1
    1.349561] mousedev: PS/2 mouse device common for all mice
    1.349874] rtc_cmos 00:02: RTC can wake from S4
    1.350226] rtc_cmos 00:02: rtc core: registered rtc_cmos as rtc0
    1.350419] rtc0: alarms up to one year, y3k, 114 bytes nvram
    1.350592] cpuidle: using governor ladder
    1.350745] cpuidle: using governor menu
    1.350899] EFI Variables Facility v0.08 2004-May-17
    1.351357] usbcore: registered new interface driver usbhid
    1.351514] usbhid: USB HID core driver
    1.351936] TCP cubic registered
    1.352183] NET: Registered protocol family 10
    1.352952] lib80211: common routines for IEEE802.11 drivers
    1.353121] lib80211_crypt: registered algorithm 'NULL'
    1.353124] Registering the dns_resolver key type
    1.353299] libceph: loaded (mon/osd proto 15/24, osdmap 5/6 5/6)
    1.353648] PM: Hibernation image not present or could not be loaded.
    1.353663] registered taskstats version 1
    1.381381]   Magic number: 13:501:117
    1.381654] rtc_cmos 00:02: setting system clock to 2013-01-23 07:06:52 UTC (1358924812)
    1.383668] Freeing unused kernel memory: 940k freed
    1.384407] Write protecting the kernel read-only data: 12288k
    1.385845] Freeing unused kernel memory: 320k freed
    1.393222] Freeing unused kernel memory: 2012k freed
    1.441862] sata_nv 0000:00:08.0: version 3.5
    1.442114] ACPI: PCI Interrupt Link [LSA0] enabled at IRQ 21
    1.442301] sata_nv 0000:00:08.0: PCI INT A -> Link[LSA0] -> GSI 21 (level, low) -> IRQ 21
    1.442652] sata_nv 0000:00:08.0: setting latency timer to 64
    1.442970] scsi0 : sata_nv
    1.443273] scsi1 : sata_nv
    1.443752] ata1: SATA max UDMA/133 cmd 0xe00 ctl 0xe20 bmdma 0xcc00 irq 21
    1.443911] ata2: SATA max UDMA/133 cmd 0xe40 ctl 0xe60 bmdma 0xcc08 irq 21
    1.445344] ACPI: PCI Interrupt Link [LSA1] enabled at IRQ 20
    1.445514] sata_nv 0000:00:08.1: PCI INT B -> Link[LSA1] -> GSI 20 (level, low) -> IRQ 20
    1.445850] sata_nv 0000:00:08.1: setting latency timer to 64
    1.446109] scsi2 : sata_nv
    1.446338] scsi3 : sata_nv
    1.446649] ata3: SATA max UDMA/133 cmd 0xe80 ctl 0xea0 bmdma 0xc080 irq 20
    1.446811] ata4: SATA max UDMA/133 cmd 0xec0 ctl 0xee0 bmdma 0xc088 irq 20
    1.744042] usb 1-9: new high speed USB device number 4 using ehci_hcd
    1.760371] ata3: SATA link down (SStatus 0 SControl 300)
    1.898043] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
    1.901255] ata1.00: ATA-7: WDC WD2500JS-00NCB1, 10.02E02, max UDMA/133
    1.901420] ata1.00: 488397168 sectors, multi 16: LBA48 NCQ (depth 0/32)
    1.904235] ata1.00: configured for UDMA/133
    1.904606] scsi 0:0:0:0: Direct-Access     ATA      WDC WD2500JS-00N 10.0 PQ: 0 ANSI: 5
    1.905082] sd 0:0:0:0: [sda] 488397168 512-byte logical blocks: (250 GB/232 GiB)
    1.905476] sd 0:0:0:0: [sda] Write Protect is off
    1.905634] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
    1.905686] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
    2.007245]  sda: sda1 sda2 < sda5 sda6 sda7 sda8 sda9 sda10 sda11 sda12 sda13 sda14 >
    2.008396] sd 0:0:0:0: [sda] Attached SCSI disk
    2.119028] usb 2-1: new low speed USB device number 2 using ohci_hcd
    2.312040] usb 2-1: New USB device found, idVendor=05af, idProduct=0003
    2.312197] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    2.312358] usb 2-1: Product: USB Keyboard
    2.312511] usb 2-1: Manufacturer: SUNREX
    2.323400] input: SUNREX USB Keyboard as /devices/pci0000:00/0000:00:02.0/usb2/2-1/2-1:1.0/input/input0
    2.323819] generic-usb 0003:05AF:0003.0001: input,hidraw0: USB HID v1.10 Keyboard [SUNREX USB Keyboard] on usb-0000:00:02.0-1/input0
    2.332327] input: SUNREX USB Keyboard as /devices/pci0000:00/0000:00:02.0/usb2/2-1/2-1:1.1/input/input1
    2.332726] generic-usb 0003:05AF:0003.0002: input,hidraw1: USB HID v1.10 Device [SUNREX USB Keyboard] on usb-0000:00:02.0-1/input1
    2.359056] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
    2.362253] ata2.00: ATA-7: ST3250310AS, 3.AAE, max UDMA/133
    2.362412] ata2.00: 488397168 sectors, multi 16: LBA48 NCQ (depth 0/32)
    2.368235] ata2.00: configured for UDMA/133
    2.368553] scsi 1:0:0:0: Direct-Access     ATA      ST3250310AS      3.AA PQ: 0 ANSI: 5
    2.368964] sd 1:0:0:0: [sdb] 488397168 512-byte logical blocks: (250 GB/232 GiB)
    2.369307] sd 1:0:0:0: [sdb] Write Protect is off
    2.369463] sd 1:0:0:0: [sdb] Mode Sense: 00 3a 00 00
    2.369485] sd 1:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
    2.481601]  sdb: sdb1 sdb2 sdb3 < sdb5 sdb6 sdb7 sdb8 sdb9 sdb10 >
    2.482552] sd 1:0:0:0: [sdb] Attached SCSI disk
    2.594035] usb 2-2: new full speed USB device number 3 using ohci_hcd
    2.682353] ata4: SATA link down (SStatus 0 SControl 300)
    2.685296] pata_amd 0000:00:06.0: version 0.4.1
    2.685353] pata_amd 0000:00:06.0: setting latency timer to 64
    2.685726] scsi4 : pata_amd
    2.685959] scsi5 : pata_amd
    2.687072] ata5: PATA max UDMA/133 cmd 0x1f0 ctl 0x3f6 bmdma 0xffa0 irq 14
    2.687231] ata6: PATA max UDMA/133 cmd 0x170 ctl 0x376 bmdma 0xffa8 irq 15
    2.794044] usb 2-2: New USB device found, idVendor=046d, idProduct=c52f
    2.794207] usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    2.794365] usb 2-2: Product: USB Receiver
    2.794519] usb 2-2: Manufacturer: Logitech
    2.806372] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:02.0/usb2/2-2/2-2:1.0/input/input2
    2.806830] generic-usb 0003:046D:C52F.0003: input,hidraw2: USB HID v1.11 Mouse [Logitech USB Receiver] on usb-0000:00:02.0-2/input0
    2.817134] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:02.0/usb2/2-2/2-2:1.1/input/input3
    2.817600] generic-usb 0003:046D:C52F.0004: input,hiddev0,hidraw3: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:02.0-2/input1
    2.849146] ata6: port disabled--ignoring
    2.861262] udevd[114]: starting version 173
    2.908454] ACPI: acpi_idle registered with cpuidle
    3.078093] usb 2-9: new full speed USB device number 4 using ohci_hcd
    3.257047] usb 2-9: not running at top speed; connect to a high speed hub
    3.275050] usb 2-9: New USB device found, idVendor=0cf2, idProduct=6230
    3.275214] usb 2-9: New USB device strings: Mfr=1, Product=2, SerialNumber=4
    3.275371] usb 2-9: Product: UB623X       
    3.275525] usb 2-9: Manufacturer: ENE Flash  
    3.275679] usb 2-9: SerialNumber: 606569746801
    3.278237] scsi6 : usb-storage 2-9:1.0
    4.287109] scsi 6:0:0:0: Direct-Access     USB2.0   CardReader CF    0100 PQ: 0 ANSI: 0
    4.305103] scsi 6:0:0:1: Direct-Access     USB2.0   CardReader SM XD 0100 PQ: 0 ANSI: 0
    4.356088] scsi 6:0:0:2: Direct-Access     USB2.0   CardReader MS    0100 PQ: 0 ANSI: 0
    4.455102] sd 6:0:0:1: [sdd] Attached SCSI removable disk
    4.473137] scsi 6:0:0:3: Direct-Access     USB2.0   CardReader SD    0100 PQ: 0 ANSI: 0
    4.495101] sd 6:0:0:0: [sdc] Attached SCSI removable disk
    4.970081] sd 6:0:0:2: [sde] Attached SCSI removable disk
    4.977064] sd 6:0:0:3: [sdf] 7815168 512-byte logical blocks: (4.00 GB/3.72 GiB)
    4.995062] sd 6:0:0:3: [sdf] Write Protect is off
    4.995220] sd 6:0:0:3: [sdf] Mode Sense: 03 00 00 00
    5.002072] sd 6:0:0:3: [sdf] No Caching mode page present
    5.002239] sd 6:0:0:3: [sdf] Assuming drive cache: write through
    5.038054] sd 6:0:0:3: [sdf] No Caching mode page present
    5.038213] sd 6:0:0:3: [sdf] Assuming drive cache: write through
    5.048099]  sdf: sdf1
    5.091066] sd 6:0:0:3: [sdf] No Caching mode page present
    5.091229] sd 6:0:0:3: [sdf] Assuming drive cache: write through
    5.091387] sd 6:0:0:3: [sdf] Attached SCSI removable disk



Oeps, dat was mijn fout (een beetje) . Ik had je moeten vragen om

dmesg | tail -20

, dan had je alleen de laatste 20 regels gehad :D…

Goed, de dingen worden gewoon gezien, niks bijzonders mee aan de hand. Kun je ook nog output posten van

mount

nadat je zo’n ding hebt aangekoppeld?

Weet je overigens ook hoe de kaartjes geformatteerd zijn ?

Kaartje staat heel onderaan (NIKON D60). Bestandsformaat is vfat (Fat 32).
Kan je ook eens kijken in de regel van OPSLAG/PICS en OPSLAG/DATA, deze oude datapartities kan ik ook niet meer beschrijven.
Daar staat bij: “type fuseblk” snap ik niet.
Dit is wel sinds deze installatie van openSUSE. Vroeger nooit problemen mee gehad (Windows, Ubuntu).
Alle andere patities kan ik wel beschrijven.

Alvast bedankt voor je tijd :wink:

lieve@dD5774E1D:~> mount
devtmpfs on /dev type devtmpfs (rw,relatime,size=2958360k,nr_inodes=739590,mode=755)
tmpfs on /dev/shm type tmpfs (rw,relatime)
tmpfs on /run type tmpfs (rw,nosuid,nodev,relatime,mode=755)
/dev/sdb10 on / type ext4 (rw,relatime,user_xattr,acl,barrier=1,data=ordered)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,relatime)
devpts on /dev/pts type devpts (rw,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /sys/fs/cgroup type tmpfs (rw,nosuid,nodev,noexec,relatime,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpuacct,cpu)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=29,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
securityfs on /sys/kernel/security type securityfs (rw,relatime)
tmpfs on /media type tmpfs (rw,nosuid,nodev,noexec,relatime,mode=755)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
tmpfs on /var/run type tmpfs (rw,nosuid,nodev,relatime,mode=755)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime)
mqueue on /dev/mqueue type mqueue (rw,relatime)
tmpfs on /var/lock type tmpfs (rw,nosuid,nodev,relatime,mode=755)
/dev/sda12 on /OPSLAG/DATA2 type vfat (rw,nosuid,nodev,noexec,relatime,gid=100,fmask=0002,dmask=0002,allow_utime=0020,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro)
/dev/sda10 on /OPSLAG/FOTO2 type vfat (rw,nosuid,nodev,noexec,relatime,gid=100,fmask=0002,dmask=0002,allow_utime=0020,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro)
/dev/sda11 on /OPSLAG/FOTO1 type vfat (rw,nosuid,nodev,noexec,relatime,gid=100,fmask=0002,dmask=0002,allow_utime=0020,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
/dev/sdb2 on /OPSLAG/MOTO type vfat (rw,nosuid,nodev,noexec,relatime,gid=100,fmask=0002,dmask=0002,allow_utime=0020,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro)
/dev/sda5 on /OPSLAG/PICS type fuseblk (rw,nosuid,nodev,noexec,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096)
/dev/sda9 on /OPSLAG/DATA type fuseblk (rw,nosuid,nodev,noexec,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096)
/dev/sdb1 on /OPSLAG/TRIAL type vfat (rw,nosuid,nodev,noexec,relatime,gid=100,fmask=0002,dmask=0002,allow_utime=0020,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro)
gvfs-fuse-daemon on /home/lieve/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,relatime,user_id=1000,group_id=100)
/dev/sdf1 on /media/NIKON D60 type vfat (ro,nosuid,nodev,relatime,uid=1000,gid=100,fmask=0022,dmask=0077,codepage=cp437,iocharset=iso8859-1,shortname=mixed,showexec,utf8,flush,errors=remount-ro,uhelper=udisks)
lieve@dD5774E1D:~> 


Maar even één tegelijk: zoals je ziet staat er bij de onderste regel voor /dev/sdf1 in de opties " ro ", wat " read only " betekent.

Voor die andere 2 zou ik graag output zien van de volgende 2 commando’s


cat /etc/fstab

cat /etc/filesystems

Hoi,
Dat ze read only staan wist ik wel, dat zag ik al in de eigenschappen, maar ik krijg ze niet terug goed.
Ik snap ook niet waarom ze read only zijn geworden.
Ik zal straks nog eens proberen en zeggen waar ik op vastloop.

Die twee partities:

lieve@dD5774E1D:~> cat /etc/fstab
/dev/disk/by-id/ata-WDC_WD2500JS-00NCB1_WD-WCANKL598907-part7 swap                 swap       defaults              0 0
/dev/disk/by-id/ata-ST3250310AS_6RY6BDC1-part6 swap                 swap       defaults              0 0
/dev/disk/by-id/ata-ST3250310AS_6RY6BDC1-part10 /                    ext4       acl,user_xattr        1 1
/dev/disk/by-id/ata-WDC_WD2500JS-00NCB1_WD-WCANKL598907-part9 /OPSLAG/DATA         ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=nl_NL.UTF-8 0 0
/dev/disk/by-id/ata-WDC_WD2500JS-00NCB1_WD-WCANKL598907-part12 /OPSLAG/DATA2        vfat       users,gid=users,umask=0002,utf8=true 0 0
/dev/disk/by-id/ata-WDC_WD2500JS-00NCB1_WD-WCANKL598907-part11 /OPSLAG/FOTO1        vfat       users,gid=users,umask=0002,utf8=true 0 0
/dev/disk/by-id/ata-WDC_WD2500JS-00NCB1_WD-WCANKL598907-part10 /OPSLAG/FOTO2        vfat       users,gid=users,umask=0002,utf8=true 0 0
/dev/disk/by-id/ata-ST3250310AS_6RY6BDC1-part2 /OPSLAG/MOTO         vfat       users,gid=users,umask=0002,utf8=true 0 0
/dev/disk/by-id/ata-WDC_WD2500JS-00NCB1_WD-WCANKL598907-part5 /OPSLAG/PICS         ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=nl_NL.UTF-8 0 0
/dev/disk/by-id/ata-ST3250310AS_6RY6BDC1-part1 /OPSLAG/TRIAL        vfat       users,gid=users,umask=0002,utf8=true 0 0
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
lieve@dD5774E1D:~> 


lieve@dD5774E1D:~> cat /etc/filesystems
vfat
hfs
minix
reiserfs
*
lieve@dD5774E1D:~> 


Hier geloof ik dat er ergens iets moet ingesteld worden, omdat openSUSE een probleem heeft met NTFS. Wat was dat ook alweer?
In Ubuntu kan ik deze partities gewoon beschrijven.

Voor die sd kaartjes. Om rechten in te stellen moet je root zijn?
Gewoon als eigenaar kan ik niets instellen.
Hier zie je de verschillende eigenschapvensters.
Het eerste eigenschappenvenster komt van een map uit /home/lieve, dan de NIKON kaart en de derde is de map /OPSLAG/PICS.
Ik dacht dat je hier dingen in kon veranderen, maar blijkbaar toch niet.
Als eigenaar moet ik wel kunnen werken op de Nikon kaart, maar in de praktijk gaat het dus niet. Hoe wordt die kaart dan gelezen. Ik snap er hoe langer hoe minder van.
Ben ik als ik de pc gewoon gebruik een “user”?

http://www.steenbeeldhouwer.be/rechten2.jpg

Als root kan ik Nautilus niet opstarten, krijg deze foutmelding:

lieve@dD5774E1D:~> sudo nautilus
Could not parse arguments: Kan display ‘’ niet opnenen


Ik weet dat het kan met de terminal, met chmod maar ik weet niet hoe.
Het gaat al fout met de naam van de map zoals je hier kan zien:

lieve@dD5774E1D:~> ls /media
NIKON D60
lieve@dD5774E1D:~> ls -l /media
totaal 32
drwx------ 4 lieve users 32768  1 jan  1970 NIKON D60
lieve@dD5774E1D:~> ls -l /media/NIKON D60
ls: kan geen toegang krijgen tot /media/NIKON: Bestand of map bestaat niet
ls: kan geen toegang krijgen tot D60: Bestand of map bestaat niet
lieve@dD5774E1D:~> ls -l /media/NIKON_D60
ls: kan geen toegang krijgen tot /media/NIKON_D60: Bestand of map bestaat niet
lieve@dD5774E1D:~> 


Wat voor naam moet ik hiervoor ingeven, één of andere cijfercode??? En moet ik chmod als root doen?

en hier ben ik nog eens. Ik kon met schijfgereedschap de kaart formatteren en heb hem ook direct een betere naam gegeven. En kijk nu eens:

/dev/sdf1 on /media/NIKON_D60 type vfat (rw,nosuid,nodev,relatime,uid=1000,gid=100,fmask=0022,dmask=0077,codepage=cp437,iocharset=iso8859-1,shortname=mixed,showexec,utf8,errors=remount-ro,uhelper=udisks)


Ik snap er niks van, maar kan er gewoon weer op schrijven.

Ik zal nu alle acties die ik voer op deze kaart bijhouden en weten te zeggen waar het weer fout loopt.
Wanneer ik heb gefotografeerd, de kaart hier aankoppel of bij mijn vriend op Ubuntu enz.

Even getest:

  1. Kaartje uit de kaartlezer gehaald dmv. “volume uitwerpen” (openSUSE)
  2. In de Nikon D60 geplaatst en foto genomen
  3. Kaart eruitgehaald en in de kaartlezer gestoken
  4. Nikon heeft de kaart beschreven met de gebruikelijke mappen plus mijn foto erin.
  5. De kaart staat weer read only !

Het gebeurt dus in het fototoestel.

Ik probeer hetzelfde met een gewone kaart, geen snelle.
Met deze kaart geen enkel probleem.

Ik schrijf het topic maar vol :wink:
Zo staat het er nu dus:

/dev/sdf1 on /media/NIKON_D60 type vfat (ro,nosuid,nodev,relatime,uid=1000,gid=100,fmask=0022,dmask=0077,codepage=cp437,iocharset=iso8859-1,shortname=mixed,showexec,utf8,flush,errors=remount-ro,uhelper=udisks)


De andere kaart:

/dev/sdf1 on /media/CANON type vfat (rw,nosuid,nodev,relatime,uid=1000,gid=100,fmask=0022,dmask=0077,codepage=cp437,iocharset=iso8859-1,shortname=mixed,showexec,utf8,flush,errors=remount-ro,uhelper=udisks)


Er staat dus hetzelfde voor beide kaarten op de naam na en de* ro* en rw
Dit terwijl ik exact hetzelfde heb gedaan met de kaarten.

Met de blauwe wijzigingen moeten in ieder geval je NTFS partities weer schrijfbaar zijn. De geheugenkaartjes is een apart verhaal, ben nu even jouw posts aan het afwerken.

Ik zag, dat je eerst een spatie in het label had. Dat was in ieder geval al een probleem. Wil je in de terminal een spatie in een map dan moet je die spatie laten vooraf gaan door een backslash (), dus

ls -l /media/NIKON\ D60

. Zelf zet ik nooit leestekens in schijflabels, maar als 't weggeschreven kan worden, zou 't ook moeten werken.

Nautilus kun je niet met sudo opstarten, daarvoor moet je

gnomesu nautilus

gebruiken.

Ik ben wel benieuwd naar de permissies als het kaartje read-only is, en dan het liefst niet grafisch, maar via


su -
ls -ld /media && ls -l /media && ls -l /media/NIKON_D60

Daar moet ergens iets verkeerd zitten.

Overigens dacht ik even dat ik ook zo’n probleem had, half uur aan het vloeken, blijkt dat dat schuifje aan de zijkant bij het in de kaartlezer stoppen verschoven was…

Schuifje staat goed, anders kon mijn fotoapparaat ook niets erop schrijven.
Maar nu staat ze weer goed, die kaart, ik snap er niks meer van.
Het is ook geen ramp dat ze af en toe gesloten blijft, enkel ongemakkelijk.
Ik blijf het testen de komende tijd.

Zojuist gedaan, nadat ik nog eens een foto heb genomen, ik kan dus weer mapjes maken in die kaart:

dD5774E1D:/home/lieve # ls -ld /media && ls -l /media && ls -l /media/NIKON_D60
drwxr-xr-x 3 root root 60 24 jan 22:35 /media
totaal 4
drwx------ 6 lieve users 4096 24 jan 22:48 NIKON_D60
totaal 20
drwx------ 3 lieve users 4096 24 jan 00:59 DCIM
drwx------ 2 lieve users 4096 24 jan 22:34 Naamloze map
drwx------ 2 lieve users 4096 24 jan 22:40 Naamloze map 2
drwx------ 2 lieve users 4096 24 jan 22:48 Naamloze map 3
-rw-r--r-- 1 lieve users  512 24 jan 00:59 NIKON001.DSC
dD5774E1D:/home/lieve # 


Klok van het fotoapparaat staat ook niet juist zie ik :slight_smile:

…Zojuist eens dat schuifje een fractie van een tiende van een mm verschoven en het werkte al niet meer., stond dus read only.
Terug in het fotoapparaat gestoken en ik kon een foto nemen.
Terug in mijn pc, foto is gemaakt en ik kan hem openen, maar de kaart staat nog steeds read only.

Even het schuifje terug tot tegen de bovenrand geduwd et voila, ik kan weer schrijven !
Dat ding moet ook altijd met een beetje geweld in de kaartlezer gepropt worden…

Merci merci, voor die simpele tip lol!

Weer zo’n geval van microhardwareprobleem, net zoals indertijd met mijn grafische kaart, even zuiver blazen en klaar.

Probleem van de andere partities doe ik later, moet gaan maffen.

Had je die post over die twee partities ook gezien, Lieve? Beetje een rommeltje zo, al die antwoorden over 2 problemen door elkaar.:D, dus je kon 'm makkelijk gemist hebben.

Jaja, heb ik gezien, maar dat is voor morgen. Ik kan mijn ogen niet meer open houden.
Slaapwel !

Hallo Knurpht, alle problemen zijn nu opgelost.
Geheugenkaartje is een kwestie van paar keer proberen ze in de kaartlezer te duwen zonder dat schuifje te veroeren.
NTFS partities kan ik nu ook beschrijven met de aanpassingen in die bestanden.
Heel hartelijk bedankt en tot de volgende :wink: