Private Internet Access VPN will not connect

Greetings,

I am relatively new to Linux, and have been toying with various distros for about 3 months now. I have settled on openSUSE, as I love it’s beauty, flexibility and the additional challenge (learning curve) it presents. The last 3 days I have been stumped by my inability to set-up a functional VPN tunnel using my Private Internet Access membership. I have searched a plethora of sites, threads, forums that deal with openSUSE, and still haven’t solved the problem. I figured if anyone can help, it would be here. Thank you in advance and namaste!

Which type of VPN? Are you using Network Manager or wicked for network management?

I’ve tried both open VPN using network manager and YaST with no avail…

I’ve tried both open VPN using network manager and YaST with no avail…

Let’s start with Network Manager controlling the network. Did you get as far as completing the VPN configuration step? If you got as far as completing the configuration, but the actual connection process fails, the next step is to find out why it is failing. For that I recommend opening a terminal window and monitor the NM logging with

journalctl -f|grep NetworkManager

Now try activating the VPN, and observe/capture the connection process events.

After entering the code, terminal goes into and eternal loop it seems. FYI - after configuring the open VPN for an US east coast…it tries to connect and immediately cycles back to off.

willb@linux-3gyy:~> journalctl -f|grep NetworkManager

You need to execute with root privileges. Use

sudo journalctl -f|grep NetworkManager

CTRL-C to terminate.