Prism54 Intersil Using intall_intersil_firmware

I got this laptop that has an expansion wireless card on it so I run the code below to find out what it is exactly.

linux-s4bx:/home/jonw # lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT8605 [ProSavage PM133]
00:01.0 PCI bridge: VIA Technologies, Inc. VT8605 [PM133 AGP]
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 42)
00:07.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:07.4 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 40)
00:07.5 Multimedia audio controller: VIA Technologies, Inc. VT82C686 AC97 Audio Controller (rev 50)
00:07.6 Communication controller: VIA Technologies, Inc. AC'97 Modem Controller (rev 30)
00:0a.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev 80)
00:0a.1 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev 80)
00:0b.0 FireWire (IEEE 1394): NEC Corporation IEEE 1394 Host Controller (rev 01)
00:0d.0 USB Controller: NEC Corporation USB (rev 41)
00:0d.1 USB Controller: NEC Corporation USB (rev 41)
00:0d.2 USB Controller: NEC Corporation USB 2.0 (rev 02)
00:0f.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
01:00.0 VGA compatible controller: S3 Inc. 86C380 [ProSavageDDR K4M266] (rev 02)
02:00.0 Network controller: Intersil Corporation ISL3886 [Prism Javelin/Prism Xbow] (rev 01)

So I next go and look under the /usr/sbin directory to see if there is a firmware install, and it turns out there is, great. I go and run it and this is my output:

linux-s4bx:/usr/sbin # ./install_intersil_firmware 
Downloading firmware
######################################################################## 100,0%
Installing firmware  End-of-central-directory signature not found.  Either this file is not
  a zipfile, or it constitutes one disk of a multi-part archive.  In the
  latter case the central directory and zipfile comment will be found on
  the last disk(s) of this archive.
unzip:  cannot find zipfile directory in one of or, and cannot find, period.

Anybody seen and been able to fix this before? Is there another way to get intersil firmware? Any help is greatly appreciated.


jonrwads wrote:
> I got this laptop that has an expansion wireless card on it so I run the
> code below to find out what it is exactly.

When asking about a device, you should post the PCI ID’s for your wireless
device? Using ‘lspci -n’ will tell. Yours are probably 0x1260, 0x3886 which the
devices table says are for Intersil PRISM Javelin/Xbow ISL3886. The in-kernel
driver for your card is p54pci, and the link for firmware is Download the XXX.arm
file and copy it to /lib/firmware/xxxx where xxx is the name you see from the
‘dmesg | grep p54’ output. It will be something like “isl3886”.

I will check the Intersill firmware installation script.


In addition, even if the script would still work, it would install the “old” firmware for prism54.ko

mv ComCard\ 54g/Win2k/WLANDCB.arm /lib/firmware/**isl3890** || die

and not firmware images suitable for the new mac80211-drivers p54pci.ko/p54usb.ko.

As the firmwares for prism-chipset are of unclear license status, openSUSE will not ship them with their distribution (like all “non-free” stuff, which has no clear license allowing redistribution).

However, I built an RPM-package “p54-firmware” which is available in my OBS-Repository.

Index of /repositories/home:/Akoellh


I will give no support on this package, so use at your own risk.

This is why I love the Linux community and Linux itself. Thank you for all of the help and it is now working perfectly. For a recap in case anyone has this same old card. I tried Akoellh solution as I am always for an easy repository and install. Unfortunately the driver was for an older version of the kernel.

So I decided to get busy and not be lazy. After downloading the arm file mentioned below a simple cp to the firmware directory, a reboot and life was good.

Thank you both for you quick response and accurate help.


The rpm contains the same files as mentioned on the linuxwireless-site (that’s where i got them from) and contains files for <= 2.6.27 and >= 2.6.29.

Which arm file?

Be more specific to help other users (and perhaps me, if I need to exchange a file in the package).

Post the output of:

ls -l /lib/firmware/isl*

md5sum /lib/firmware/isl*

I will have to get back to you on the details of all of this as the laptop is not with me right now. After it started to work my wife all of the sudden wanted it. Anyway the information I can give you is this.

I set up the repo using the 11.1 directory. I selected the Prism driver and it gave me the message saying it was going to downgrade the kernel.

The arm file I downloaded was from the post lwfinger which I have posted again. p54 - Linux Wireless

When I get that laptop back I will post the requested outputs.

Certainly not because of the firmware package but as there are quite a few kmp-packages in my repo which depend on a certain kernel version, you should use repo “openSUSE_Version_Update” if you already made a kernel update since installation.