Printing trouble - 13.2 beta1 KDE 32-bit

I am having printing trouble with beta1.

I installed 13.2 beta1 32-bit KDE kernel-default on a ThinkPad X41 with legacy BIOS boot. It was the full DVD version written to a USB stick. I used ext4 file systems, and formatted / and /home.

The installation went smoothly. I got wireless connected with Network Manager. I used YaST to install hplip-3.14.6, and ran HP Device Manager to set up our network printer, an HP LaserJet Pro MFP M127fn. This setup worked the same as it had on several machines with openSUSE 13.1 and hplip 3.14.6. However, a test page would not print - no response. I deleted hplip with YaST, then downloaded the installer from sourceforge. I ran it, it reported it did not support 13.2, but would use the 13.1 files. I continued and it pulled in a number of dependecies as follows:

error: suse-13.2beta1 version is not supported, so all dependencies may not be installed. However trying to install using suse-13.1 version packages.  

warning: There are 8 missing REQUIRED dependencies.
note: Installation of dependencies requires an active internet connection.
warning: Missing REQUIRED dependency: gcc (gcc - GNU Project C and C++ Compiler)
warning: Missing REQUIRED dependency: libpthread (libpthread - POSIX threads library)
warning: Missing REQUIRED dependency: python-devel (Python devel - Python development files)
warning: Missing REQUIRED dependency: cups-devel (CUPS devel- Common Unix Printing System development files)
warning: Missing REQUIRED dependency: libusb (libusb - USB library)
warning: Missing REQUIRED dependency: libtool (libtool - Library building support services)
warning: Missing REQUIRED dependency: cups-image (CUPS image - CUPS image development files)
warning: Missing REQUIRED dependency: libjpeg (libjpeg - JPEG library)

warning: There are 7 missing OPTIONAL dependencies.
note: Installation of dependencies requires an active internet connection.
warning: Missing REQUIRED dependency for option 'network': libcrypto (libcrypto - OpenSSL cryptographic library)
warning: Missing REQUIRED dependency for option 'network': libnetsnmp-devel (libnetsnmp-devel - SNMP networking library development files)
warning: Missing OPTIONAL dependency for option 'network': avahi-utils (avahi-utils)
warning: Missing OPTIONAL dependency for option 'gui_qt4': python-notify (Python libnotify - Python bindings for the libnotify Desktop notifications)
warning: Missing REQUIRED dependency for option 'fax': dbus (DBus - Message bus system)
warning: Missing REQUIRED dependency for option 'scan': sane-devel (SANE - Scanning library development files)
warning: Missing OPTIONAL dependency for option 'scan': xsane (xsane - Graphical scanner frontend for SANE)

I used the newly installed version to set up the network printer again, which worked normally. With this, HP Device Manager prints a test page on four sheets, in pieces that did not even form the entire page. An image of one 8½ x 11 inch sheet is:
Using YaST Printer Configuration page to try to print a test page sent nothing to the printer. The CUPS error log is at

I tend to think something in CUPS is incorrect. IIRC, I have never had to do anything with CUPS in the last several versions of openSUSE and hplip. Once the printer was installed and configured, it just worked.

Is anyone else seeing something like this in 13.2 beta1?


I have a different printer, and as I noted in the “Pre-Release/Beta” forum using a YaST/hplip combination the printer install just worked for me. I note thou my printer supports DirectJet and also it has a fixed IP address on my LAN that I know.

So the philosophy I follow when installing is to watch for network setup options that use DirectJet and also go for a manual entry of the IP address when given a choice.

I use YaST as a front end, BUT before running YaST I install ‘hplip’ as YaST will act as a front end to hplip if hplip is installed.

With that for my printer, its pretty simple with nothing complex, but I do follow a fair number of VERY quick steps to get it to work.

  1. YaST > Hardware > Printer
  2. select "Print via Network
    " 1. select "Connection Wizard
    " 1. Go to "Access Network Printing or Printserver Box via:
    " and then select “TCP Port (AppSocket/Jet Direct)” 1. and enter my printer’s IP address in "IP Address or Host Name
    ". Press “test connection” (and receive an ok that the printer is found). Then I select “HP” for the printer driver and press “OK”. 1. the printer drivers then load. After they are loaded and asks one to make a drive selection, I do NOT do that. Instead I select “A4” for my European printer size
  3. instead of selecting an HP printer, in the lower right corner I select "run hp-setup
    " 1. and in the menu that comes up I select "Network/Ethernet/Wireless Network (direct connection or JetDirect)
    " 1. I then select "Show Advanced Options
    " 1. I then select "Manual Discovery
    " 1. then enter the printers IP address under "IP Address or Network Name
    ". 1. this will then discover the printer and automatically select the right driver
  4. its very obvious and intuitive after this …

I can’t help but think that the wrong driver was installed.

I had a case a couple of years back where for my printer there were two HP C309a printer options offered. One option was a bug in hplip and if that was selected I would get garbage when printing. If I selected the other it would print ok.

I am NOT saying this (two possible printer options) is what you encountered, as I think it unlikely, but I am saying I am thinking there is something wrong with the printer driver selected.

I have the exact same problem, but with a different printer.
I have a Lexmark Prospect Pro209 inkjet printer. I download the driver from their website (they have the driver for OpenSuse 12.1). It worked flawlessly on 13.1. Now, on 13.2, the exact same driver, on the exact same computer does the same as the OP printer. The test page prints in 4 pages.
Even if i print just a single line of text from libreoffice or scribus, the line comes out in 2 pages, always about 5cm (2 inches) from the left border.

Any help would be very welcome. Thank you.

Reading your comments further - this is a beta release, and by deleting the SuSE-GmbH version and going for the HP version (where the HP version reports it is not supported by 13.2) you then ran into problems with your PC installing the HP hplip version, and to me that suggests you could have more than one problem. One with the SuSE-GmBH packaged hplip and another with the HP version.

IMHO you are better off to go back to the SuSE-GmbH packaged version (that failed to print) and raise a bug report on 13.2 beta1 - and investigate why there was a failure to print.

Thanks for the details. They read like exactly what I have done successfully on several machines, including the “Manual Discovery”. Like you said, it just worked before.

I’ll do the full 13.2 beta1 installation from scratch again, and take notes of what happens.

I had installed 13.2 milestone0 and some of the subsequent snapshots, and I believe printing worked with them. If beta1 printing does not work here, I may try to get an earlier snapshot and see if my memory is correct.

This ThinkPad X41 has two hard drives, one with 13.1, one for testing now with 13.2 beta1. Running 13.1, printing works correctly. Running 13.2 beta1, printing is not working at the moment.


Thanks for posting. I was beginning to think mine was the only problem. Your experience with other than hplip makes me think maybe the problem is in CUPS.

Did you format /home partition when installing 13.2, or keep an existing version of /home?


I did a full format ( i don’t have a separated /home partition).

So far, it’s the only problem i found on 13.2. It would be very nice if it could be corrected somehow for the final version…

You need to report it to get it fixed. First be sure it is reproachable and it is only concerning OS software (no one but the provider can do anything much with non open source) then see if anyone else has reported it if so add your observations if not fill in a report.

Note in case you don’t know though you should if you run beta is where/how to report

It is reproducible, and there is now a fix available in the Printing repository.

I did a fresh installation as described by oldcpu in above.
The hplip set up selected driver /usr/share/cups/model/manufacturer-PPDs/hplip/hp-laserjet_pro_mfp_m127fn-hpijs.ppd.gz
Using that to print a test page gave no result. The working 13.1 installations use driver hp-laserjet_pro_mfp_m127fn-hpcups.ppd.gz so I changed to that and got the four-sheet test page.

I added the repository at and switched all 20 installed packages to it. That was about 9 PM San Francisco time, 28 Sep 2014. There was no change in printing behavior - still a four-sheet test page.

Ever optimistic, I checked the repository about noon PDT today 29 Sep, and many of the packages had updates available. I installed those and, lo and behold, printing now works correctly. The test pages from both HP Device Manager and YaST Printer Configuration were good, as were prints of a PDF file and a LibreOffice Writer document.

Let’s hope these latest packages make it into 13.2 soon.


My laptop (factory 32 bits version) is also printing ok now! I guess i will change my main PC to Factory also.

Thanks all.

You do understand the concept of Beta software. ie things may be and probably are broken it is up to the beta testers (you) to report any problems uncovered. Looks like this one got fixed, but I know there are more. You should not be running a production system (even a desktop you rely on) on beta software. If you do be sure tobe very dilegent in backing up important data.

Thats great news - but I am concerned that if one can’t locate a supporting bug report, then these packages may not make it in to 13.2.

Looking through bugzilla, I did note one bug on printing in openSUSE-13.2 where they noted there was a fix in factory and that fix would be applied to openSUSE-13.2. But I have no idea if that might mean the fix you tried , or a different one is to be applied.

IMHO, the safest course, dependent on how bad you want this fix in openSUSE-13.2, is to write a bug report. In the bug report one can describe the failure, and note also the factory version(s) of packages that fixed the problem. That will give the SuSE-GmbH packagers a good indication of the need for that factory update to make it into 13.2. By also identifying the packages that fixed the problem, the packagers will be able to close the bug report fairly quickly and not waste much time on it.

Good luck, and I’m most happy to read that you have made progress here.

Bug report is at

Bugzilla format certainly has changed since my last visit, as you mentioned in


Many thanks. That is an educational bug report with response. I am not sure what that bodes for openSUSE-13.2, as upstream bug reports can be slow sometimes to have addressed. Hopefully the factory version that works for you (possibly with a SuSE-GmbH patch ?? ) will be continued until the upstream problem in hplip is addressed.

I installed openSUSE-Factory-DVD-i586-Snapshot20141001-Media.iso, and it still gives the four-sheet test page. Switching to the Factory Printing repository fixed it, after rebooting.

This was exactly my issue with my 13.2RC1 machine that I updated to 13.2 release.

hpcups driver picked by HPLIP: pages split into four (one-fourth up, maybe?).
hpijs driver selected manually after setup: prints as expected.