printing problem with CUPS over LAN

This is likely a CUPS problem more than a network problem, but there isn’t a printing forums here, and is not helpful at all, so here goes:

(Clent pc is openSuse 11 & CUPS 1.3.7 , printserver is 10.3 & CUPS 1.2.12, Other PCs are Win xp and Vista. printer is connected to server by USB)

The printer prints from the server and from either Windows PC OK. From the SUSE 11 PC I can send a test print from CUPS OK but not print from any appication. I’ve tried using YAST on the client PC to set to print to both the local queue and the remote one, no difference.

If I try to print from an application (tried OpenOffice, Kwrite, Thunderbird, Inkscape and Gimp). using File>Print or the printer button (if available) the result is always the same. The print dialog box comes up, I confirm the correct printer is selected then click OK. Then nothing happens. The dialog box disappears and that’s it.

I’ve checked the “Completed Jobs” list in CUPS on both the client and the server and neither shows the missing job at all.

Any suggestions?



further investigation made it clear that the CUPS installation on the suse 11 client was corrupt. I removed and reinstalled CUPS then recreated the very same setup form scratch… problem solved.