Printing problem new info

In a previous thread we tried to fix a printing problem that was never resolved. I have an HP Envy 5070. We approached the problem as a hardware problem but it must be a software problem. A short recap: the printer will not print type properly, if at all. The problems were tackled by changing fonts, OS, computer, file format and nothing worked.

I just created a Christmas card in Google Docs. I intended to send it to a neighbor for printing. I zypper dup every few days, so I decided to try a print in case software updates fixed the problem. Unfortunately, the typing was still almost blank. But, the Word Art and Clip Art printed perfectly. So, I deleted all text and replaced it with Word Art. Once again, it printed perfectly and I had my Christmas card.

Any ideas on resolving this problem, other than creating all my docs in Word Art and Clip Art?

As I haven’t seen the previous thread, the best I can do is start from scratch.

My first impression is that, so long as you have only tried this using Linux distros, that maybe CUPS doesn’t support that model.

The next thought I have is… let’s say you create a very simple document — a text-only document — in Text Edit or Gedit or whatever and you print, what settings are you by default using? Is it trying to print the text using the CMY cartridge, is it printing “enhanced” black which is K + CMY, or is it printing in straight black? Fundamentally, for something like this, you need to start with the absolute basics and work your way up from there.

Ideally, you should normally print straight black text using ONLY your black cartridge, and that won’t happen if you have some other setting.

Now, if you can print on this printer using similar software but in macOS or Windows and that works without issue, then you will know there’s a compatibility issue.

According the CUPS/HPLIP printer support page, the Envy 5070 is not even listed. So it seems completely unsupported by CUPS/HPLIP yet.
https://developers.hp.com/hp-linux-imaging-and-printing/supported_devices/index

The closest hit would be to test with the Envy 5000 driver…

If you are referring to this topic…

…then you mentioned that the same document when printed from Windows environment also had issues, leading us to speculate about it being a document (formatting) issue. I did ask if printing other types of files was successful, but some of your replies were a bit vague.

Can you take a photo of (or scan, if you have a flatbed scanner) the output so we can see what the problem you’re having looks like?

Yeah, I was looking at the CUPS device support list over on openprinting, and I didn’t even see the Envy category listed at all. That’s what’s kind of making me think this is an incompatibility issue.

Going to try to respond to all questions.
Yes, this is an updated thread based on “Printer Errors” thread that I started (I’m at a loss on how to reference it more fully in the new forum.)

I booted into Windows 10, selected a Google Doc online and tried to print. Blank pages came out.
I downloaded that doc as .docx, .odt and .txt with the same result: blank pages.
I booted into Tumbleweed and got the same results trying to print. I did, however, get output trying to print a .jpeg of a photo. The colors were way off but at least there was output on the page.
I took a screenshot of a spreadsheet with Spectacle and printed that. I got output but instead of printing black, normal, print, I got a blueish font that was outlined, not solid.
As I stated previously, Word Art prints normally.

There is an hplip driver diagnosis in the HP Device manager. It threw about 20 errors for missing files it said I should update manually. But the diagnosis says it could not diagnose errors on hplip above version 3.15 and I have version 3.22 installed. Yast shows only one rev back (3.21) so I didn’t bother replacing hplip. Since the errors are based on hplip 3.15, I didn’t install the missing files. Most of those were development files and Yast said only developers needed them. I was going to post the output of the diagnosis but I don’t see the code tags in the new forum.

Have read of the following:

You can also use the BBCode style tags as with the previous forum: [code]…[/co…

Ok, so that probably means there’s something up with formatting in the document.

Going back to what I suggested earlier, if you create a from-scratch new document of the most basic kind (a text document using a text editor) and print that, whether in Windows or in openSUSE, does that print normally or not? Then, if you create a new document using something local, like LibreOffice Writer, and again keep it as basic as possible (new document, type some text, do not format it in any way) and print, what happens?

Before we worry any more about your Google Doc document, we need to know you can create something from scratch, 100% locally, and that that prints normally.

Short of the rest of us having access to your documents (which I am not suggesting in any way that you do) there’s no real good way for us to know more specifically where the problem is.

Because here’s the thing: is your printer actually printing the contents of the document (but in a way that is barely perceptible) or is it really not printing anything at all? Anyone who’s used a word processor for any real length of time has probably encountered situations where a document that should print fine doesn’t, and it’s for some random (and occasionally obscure) reason. And anyone who’s been around in the tech world long enough has also encountered all manner of other weirdness coming out of left field which impacts any of a zillion things which has us scratching our heads.

Copy the URI of the thread (https://forums.opensuse.org/t/printer-errors/153880) and paste it here:

Thank you for all your efforts to help me resolve this problem. I will be away from the printer for a few days but when I return I will try to print using the suggestions given here. Just some thoughts before this old guy forgets: this printer is not new. I have used it successfully for many months. So, I thought some update broke it.

HP’s compatibility list shows Envy printers in series older and newer than this series 5000, but not this actual series. Yet, when installing the driver, this hplip is shown for the 5000 series.

My failed attempt at printing a text file came when I did a copy/paste of the Google doc into Kate as a txt file. I thought that would strip troublesome formatting. Like all other versions of the file, this page output was completely blank. It SOUNDS like its printing but no ink is deposited. I will create a new file in Kate to see what happens.

Here is the output of the HP Device Manager diagnosis (thanks Dino_Ferrari):


HP Linux Imaging and Printing System (ver. 3.22.6)
Self Diagnse Utility and Healing Utility ver. 1.0

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.


HP Linux Imaging and Printing System (ver. 3.22.6)
Self Diagnse Utility and Healing Utility ver. 1.0

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

 

Checking for Deprecated items....
error: This distro (i.e suse  20221224) is either deprecated or not yet supported.
The diagnosis is limited on unsupported platforms. Do you want to continue?(y=yes*, n=no):y


Checking for HPLIP updates....

HP Linux Imaging and Printing System (ver. 3.22.6)
HPLIP upgrade latest version ver. 1.0

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

HPLIP upgrade is disabled by openSUSE for security reasons, see https://bugzilla.suse.com/show_bug.cgi?id=853405 - if you like to upgrade HPLIP, use an openSUSE software package manager like YaST or zypper.

Done.
error: Failed to upgrade latest HPLIP. Is hp-upgrade already running (i.e. foreground or background)?


Checking for Dependencies....
warning: 3-20221224 version is not supported. Using 3-15.3 versions dependencies to verify and install...

---------------
| SYSTEM INFO |
---------------

 Kernel: 6.1.0-1-default #1 SMP PREEMPT_DYNAMIC Wed Dec 21 16:29:21 UTC 2022 (ab10a11) GNU/Linux
 Host: localhost.localdomain
 Proc: 6.1.0-1-default #1 SMP PREEMPT_DYNAMIC Wed Dec 21 16:29:21 UTC 2022 (ab10a11) GNU/Linux
 Distribution: 3 20221224
 Bitness: 64 bit


-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.22.6
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for 3 distro  20221224 version 

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf.  Generated from hplip.conf.in by configure.

[hplip]
version=3.22.6

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/cups/model/manufacturer-PPDs/hplip
ppdbase=/usr/share/cups/model/manufacturer-PPDs
doc=/usr/share/doc/packages/hplip
html=/usr/share/doc/packages/hplip
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/lib/cups/driver
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=yes
foomatic-drv-install=no
foomatic-ppd-install=yes
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=no
cups-ppd-install=yes
internal-tag=3.22.6
restricted-build=no
ui-toolkit=qt5
qt3=no
qt4=no
qt5=yes
policy-kit=no
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=no
class-driver=no


Current contents of '/var/lib/hp/hplip.state' file:
Plugins are not installed. Could not access file: No such file or directory

Current contents of '~/.hplip/hplip.conf' file:
[commands]
scan = 

[fax]
email_address = 
voice_phone = 

[installation]
date_time = 12/26/22 11:32:07
version = 3.22.6

[last_used]
device_uri = "hp:/net/ENVY_5000_series?ip=192.168.1.112"
printer_name = 
working_dir = .

[polling]
device_list = 
enable = false
interval = 5

[refresh]
enable = false
rate = 30
type = 1

[settings]
systray_messages = 0
systray_visible = 0

[upgrade]
last_upgraded_time = 1661882119
notify_upgrade = true
pending_upgrade_time = 0


 <Package-name>        <Package-Desc>      <Required/Optional> <Min-Version> <Installed-Version> <Status>   <Comment>

-------------------------
| External Dependencies |
-------------------------

 cups                 CUPS - Common Unix Printing System                           REQUIRED        1.1             2.4.2           OK         'CUPS Scheduler is running'
 gs                   GhostScript - PostScript and PDF language interpreter and previewer REQUIRED        7.05            9.56.1          OK         -
 error: xsane         xsane - Graphical scanner frontend for SANE                  OPTIONAL        0.9             -               MISSING    'xsane needs to be installed'
 scanimage            scanimage - Shell scanning program                           OPTIONAL        1.0             1.1.1           OK         -
 error: dbus          DBus - Message bus system                                    REQUIRED        -               1.14.4          MISSING    'DBUS may not be installed or not running'
 error: policykit     PolicyKit - Administrative policy framework                  OPTIONAL        -               121             MISSING    'policykit needs to be installed'
 network              network -wget                                                OPTIONAL        -               1.21.3          OK         -
 error: avahi-utils   avahi-utils                                                  OPTIONAL        -               -               MISSING    'avahi-utils needs to be installed'

------------------------
| General Dependencies |
------------------------

 error: libjpeg       libjpeg - JPEG library                                       REQUIRED        -               -               MISSING    'libjpeg needs to be installed'
 error: cups-devel    CUPS devel- Common Unix Printing System development files    REQUIRED        -               2.4.2           MISSING    'cups-devel needs to be installed'
 error: cups-image    CUPS image - CUPS image development files                    REQUIRED        -               2.4.2           MISSING    'cups-image needs to be installed'
 error: libpthread    libpthread - POSIX threads library                           REQUIRED        -               b'2.36'         MISSING    'libpthread needs to be installed'
 error: libusb        libusb - USB library                                         REQUIRED        -               1.0             MISSING    'libusb needs to be installed'
 sane                 SANE - Scanning library                                      REQUIRED        -               -               OK         -
 error: sane-devel    SANE - Scanning library development files                    REQUIRED        -               -               MISSING    'sane-devel needs to be installed'
 error: libavahi-dev  libavahi-dev                                                 REQUIRED        -               -               MISSING    'libavahi-dev needs to be installed'
 error: libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED        5.0.9           5.9.3           MISSING    'libnetsnmp-devel needs to be installed'
 error: libcrypto     libcrypto - OpenSSL cryptographic library                    REQUIRED        -               1.1.1           MISSING    'libcrypto needs to be installed'
 python3X             Python 2.2 or greater - Python programming language          REQUIRED        2.2             3.10.9          OK         -
 python3-notify2      Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL        -               -               OK         -
 error: python3-pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4                         OPTIONAL        4.0             -               MISSING    'python3-pyqt4-dbus needs to be installed'
 error: python3-pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x)         REQUIRED        4.0             -               MISSING    'python3-pyqt4 needs to be installed'
 python3-dbus         Python DBus - Python bindings for DBus                       REQUIRED        0.80.0          1.2.18          OK         -
 python3-xml          Python XML libraries                                         REQUIRED        -               2.5.0           OK         -
 error: python3-devel Python devel - Python development files                      REQUIRED        2.2             3.10.9          MISSING    'python3-devel needs to be installed'
 python3-pil          PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL        -               9.3.0           OK         -
 python3-reportlab    Reportlab - PDF library for Python                           OPTIONAL        2.0             3.6.7           OK         -

--------------
| COMPILEDEP |
--------------

 error: libtool       libtool - Library building support services                  REQUIRED        -               -               MISSING    'libtool needs to be installed'
 error: gcc           gcc - GNU Project C and C++ Compiler                         REQUIRED        -               -               MISSING    'gcc needs to be installed'
 error: make          make - GNU make utility to maintain groups of programs       REQUIRED        3.0             -               MISSING    'make needs to be installed'

---------------------
| Python Extentions |
---------------------

 cupsext              CUPS-Extension                                               REQUIRED        -               3.22.6          OK         -
 hpmudext             IO-Extension                                                 REQUIRED        -               3.22.6          OK         -

----------------------
| Scan Configuration |
----------------------

 hpaio                HPLIP-SANE-Backend                                           REQUIRED        -               3.22.6          OK         'hpaio found in /etc/sane.d/dll.conf'
error: NOT FOUND OR FAILED TO LOAD! Please reinstall HPLIP and check for the proper installation of scanext.
 error: scanext       Scan-SANE-Extension                                          REQUIRED        -               3.22.6          MISSING    'scanext needs to be installed'

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

device `hpaio:/net/ENVY_5000_series?ip=192.168.1.112' is a Hewlett-Packard ENVY_5000_series all-in-one


--------------------------
| DISCOVERED USB DEVICES |
--------------------------

No devices found.

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

 
ENVY_5000
---------
Type: Printer
Device URI: hp:/net/ENVY_5000_series?ip=192.168.1.112
PPD: /etc/cups/ppd/ENVY_5000.ppd
PPD Description: HP Envy 5000 Series, hpcups 3.22.6
Printer status: printer ENVY_5000 is idle.  enabled since Mon 26 Dec 2022 12:28:25 AM EST
Communication status: Good


--------------
| PERMISSION |
--------------

Missing Required Dependencies
-----------------------------
error: 'dbus-1-devel' package is missing/incompatible 
error: 'python-gobject2' package is missing/incompatible 
error: 'libjpeg-devel' package is missing/incompatible 
error: 'zlib-devel' package is missing/incompatible 
error: 'cups-devel' package is missing or 'cups' service is not running.
error: 'cupsddk' package is missing or 'cups' service is not running.
error: 'cups-devel' package is missing or 'cups' service is not running.
error: 'glibc' package is missing/incompatible 
error: 'libusb-1_0-devel' package is missing/incompatible 
error: 'libusb-1_0-0' package is missing/incompatible 
error: 'sane-backends-devel' package is missing/incompatible 
error: 'libavahi-devel' package is missing/incompatible 
error: 'net-snmp-devel' package is missing/incompatible 
error: 'openssl' package is missing/incompatible 
error: 'python3-devel' package is missing/incompatible 
error: 'libtool' package is missing/incompatible 
error: 'libgphoto2-devel' package is missing/incompatible 
error: 'rpm-build' package is missing/incompatible 
error: 'gcc-c++' package is missing/incompatible 
error: 'make' package is missing/incompatible 
Missing Optional Dependencies
-----------------------------
error: 'xsane' package is missing/incompatible 
error: 'avahi-utils' package is missing/incompatible 
error: 'dbus-1-python3-devel' package is missing/incompatible 
error: 'dbus-1-python3' package is missing/incompatible 


ENTER ROOT/SUPERUSER PASSWORD
-----------------------------
Please enter the root/superuser password: 
Do you want to update repository and Install missing/incompatible packages. (a=install all*, c=custom_install, s=skip):s
Install manually above missing/incompatible packages.


Checking Permissions....


Checking for Configured Queues....
 
Queue(s) configured correctly using HPLIP.


Checking for HP Properitery Plugin's....
No plug-in printers are configured.
 
Diagnose completed...

It next asked to update the files but I did not since the update was for an older version of hplip. If harmless, I will update /install the listed files. I tried both the tick mark and code tag method to present this output but it seems not to have worked for color. One more item: I emailed the Google doc to my neighbor with an HP printer on Windows 10. It printed properly.

Well, this was embarrassing. I subscribed to Instant Ink from HP with the lowest usage. I got notice that I was about to run over my quota. That annoyed me since most of the pages I have printed were cleaning and other pages trying to resolve the print quality issue. So, I went on Chat with HP to complain.

After quite a long time online with different reps, it turns out to be a hardware problem, not a software problem. The black printhead is defective or worn out. This did not occur to me since I thought the “head” was integrated in the ink cartridge and I replaced those. One rep told me to take out the black cartridge and try printing. To my entire amazement, not only did it print, the print appeared to be black! It must be very dark blue, but that is ok. The printer is out of warranty and fixing it will cost more than I paid for it. So, I will use up all the ink I can and then buy a new printer. I’ve used HP printers for decades and this is the first problem I ever had.

My sincere thanks (and apologies) for all the effort put into trying to help me.

1 Like

Even a test print from the printer itself should have helped you pick this up. The symptoms would also have been the same when printing from Windows, so that would have eliminated any Linux software-related cause.

Oh, no problem at all.

However, I do have some thoughts about what you might want to do, going forward. I’m going to very quickly start with some history to give context, and then move forward.

In the “normal human being” space, the first printers were dot matrix. In the mid-80s, laser printers started to come out, with probably the most famous and for a time most ubiquitous one being Apple’s LaserWriter. This would eventually be replaced by the LaserWriter II, IInt, and IIntx. These and some other models came out, but they were very expensive (anywhere from $1500 - $4000, iirc). In the late 80s/early 90s, inkjet printers were introduced, and at anywhere from $300-$500, they offered a budget alternative to laser printers for those wanting something nicer than a dot matrix printer. Laser printers never died; rather, they continued to evolve and improve, as did inkjet printers, increasing in resolution and adding in color.

Along the way, manufacturers decided to start making their printers literally (or figuratively) “loss leaders” and changed their cartridge business model as well, and to this day, printer makers make all their money and profit on cartridges, except for the highest-end (and usually commercial) units, where there’s enough opportunity to put a goodly profit margin on the printer itself. And then, over time, as cartridges became more expensive, companies started springing up with ways to refill cartridges, or with remanufactured cartridges, etc. This turned into a cat-and-mouse game as printer manufacturers did what they could to obstruct competitors.

At this point, the only real advantage of inkjet printers is those with so-called “photo printing” capability, because when used in combination with appropriate specially-coated paper, they can produce output that rivals traditional camera-film-paper finished products. However…

It happens to be that if one’s use case is printing photos, as long as you’re not printing large quantities, it is cheaper to take your images to your local Walmart or corner drug store (Walgreens, for example) and pay them to print for you. You have no investment in equipment, you do not have to keep a stock of paper on hand, and you have $0 maintenance costs. Also, typically, the price per print is about the same as what you pay if you did it yourself; in many cases it’s even a few pennies cheaper.

Apart from cost, two major downsides to inkjet printers are dealing with dried out and/or clogged-up cartridges or separate print heads (such as you’re going through) and the low capacity of cartridges. The majority of what’s printed, by the majority of people printing things, is BLACK. So, most of the time and for most people, even if you’re actively printing things, black gets used far and away more than color.

A lot of businesses and even school districts have cottoned on to what I just wrote. Going on probably two decades ago, the county school district I live within got rid of all their inkjet printers and went to networkable, centrally-installed black-only laser printers, and then if the school needed on-site color printing, they would buy one or two color laser printers, or for art schools they would (also) buy a specialty color inkjet for that class. Normally those types of printers are 11x17" sheet-size capable printers, or even larger than that.

What I would strongly suggest is that you do some research into available laser printers, whether black-only or color, because the cartridges are generally a LOT larger than inkjet printers, and generally you get a LOT more pages per toner cartridge than pages per inkjet cartridge.

I personally owned just a black-only HP LaserJet P1102w, and for years that’s what I would print everything from. I could get a LOT more pages per cartridge, and of course there’s never a concern about a printhead fouling due to dried ink, or an ink cartridge or ink tank drying out. A little over a year ago I upgraded and bought an HP Color LaserJet m255dw because I print “just enough” color to need a color printer, and for the most part I don’t print photos but color documents.

Anyhow, that’s my 2¢ worth on the matter.

1 Like

This is more like $20 worth than 2 cents! Thank you for the time and effort. With greater adoption of electronic communication of all kinds, I find myself printing hard copies less and less often. That is one reason I missed the obvious solution of having a hardware problem. I just assumed dried out cartridges from lack of use. When cleaning didn’t help, I jumped to drivers. I, too , saw the specific model was not included in HP’s linux website. But since it had been working for a number of years, I ignored the omission and assumed a Tumbleweed update was the culprit.

Now, I have to take the advice of assessing my true needs to determine what my replacement printer will be. Laser seems like overkill when I print only a few pages per month. But I will consider the economics. I print color occasionally and almost never photos. So, taking advantage of Google’s photo printing might make sense on the rare instance that I want to print something more than a chart.

The business model of “giving away” a printer to sell cartridges is as old as giving away razors so people have to buy the blades. In fact, the direct replacement for my printer’s capabilities can be had for $49 or $59 for a souped up model. You could spend more than that on replacing 2 cartridges.

Once again, thanks to all for help and advice.

We have three printers here a brother laser, brother inkjet and a hp. We prefer the brother especially the inkjet.
The ink last longer even when it automatically clean the cartridge every night. There was one time I seldom use the color ink and it lasted for six months without drying for not being used.