Printing Problem HP PSC 1350

New to Linux. My printer is HP PSC 1350 All in One. Suse11.1 recongised printer as HP 1300 type and suggested driver HP Deskjet. So I have everything that looks like working, but when I print, it simply does not print. It does all the right things – puts document in queue, shows as sending to printer, but never prints…

It does print by default under other distributions without a problem – Mandriva and Ubuntu, for example. So,the problem is with suse11.1 and I need your help to figure it out.


those using HP printers recommend installing a package called hplip which should be findable and installable; good luck;

I suspect it is in the main repo for opensuse, but my information may need correcting if it is not right

I deleted current driver. Downloaded and installed the latest HPLIP and then reinstalled the printer driver. Now it prints. Thanks.

great; glad it worked;

in this recent posting too,


connecting a HP scanner to a network was covered and this post

HP Network Scanner Configuration -

guided how to use hplip and YaST

Choose the run hp-setup option

all seemed to be covered there for a network connection

I have another question here. It does print well not, but everything is so pale… I looked through configuration tool and tried to improve quality, but it does not help. The printout is very pale regardless whether it is doc, pdf, or picture. Any solution?

PS. In Win XP it prints black as it should. Even in Linux when I did alignment of cartridges it printed black…

I have no idea but I wonder if you look in CUPS;

enter this in your web browser:


are there any settings there that you can alter?

Actually, I just needed to make sure it is 300 dpi normal mode not draft or 600 dpi. Now it prints perfectly. Thanks to all.

great! enjoy your system