Printing on a remote "Zebra" problem.....

I am facing a little printer problem, when i try to print a bar code on a remote “Zebra” that is installed on a windows machine, it simples refuses to print but i can see the job on xp pooling .

On windows machine this printer was installed using “generic driver” only for “text” so under xp if i just type on prompt “type myfile.txt>lpt1” it prints just the way i want but on the oder hand on my suse machine if i do “lpr -Pgeneric myfile.txt” it isends to my remoto printer but nothing happens…

i’ve tried already may be all “generics and zebra” drivers but no luck …
the support guys here say that there is no need for specific driver…

any idea…

myfile.txt sample


FK
FN
N
I8,A,003
q824
R5,5
S2
D24
ZT
N
A300,370,4,1,1,1,N,"17/03/2010 18:16:10  TM"
A320,245,5,1,1,1,N,""
A300,350,4,1,1,1,N,"39a2m10d Masc "
A390,338,4,1,1,1,N,""
A520,20,5,2,1,1,N,"TTT-UNIDADE TESTE 1"
A500,20,5,2,1,1,N,"000001-POSTO 01 TESTE YYYYY"
A300,22,4,1,1,1,N,"SORO"
A300,37,4,1,1,1,N,"TUBO AMARELO"
A49,225,3,1,1,1,N,""
B479,50,5,2,2,6,85,N,"020535835915"
A393,100,5,1,1,1,N,"020535835915-500423115893"
A380,140,5,1,1,1,N,"1026464539"
A368,56,5,1,1,1,N,"TESTE ADRIANO BALA"
A60,210,0,1,1,1,N,""
A348,50,5,1,1,1,N," TGO TGO"
A300,2,4,2,1,1,R,"7755923 BIO YYYYY"
P1
FE

On 2010-06-25, eroskoller <eroskoller@no-mx.forums.opensuse.org> wrote:
>
> I am facing a little printer problem, when i try to print a bar code on
> a remote “Zebra” that is installed on a windows machine, it simples
> refuses to print but i can see the job on xp pooling .
>
> On windows machine this printer was installed using “generic driver”
> only for “text” so under xp if i just type on prompt “type
> myfile.txt>lpt1” it prints just the way i want but on the oder hand on
> my suse machine if i do “lpr -Pgeneric myfile.txt” it isends to my
> remoto printer but nothing happens…

If the job really remains in the ‘Spooling’ state in the Windows queue, try
defining/shortening the timeout in the Windows printer setup. I might be it
never receives and end-of-job signal. (EOF or closing of stream)

Can’t tell you where this option is, haven’t got a Windows machine here.


Any time things appear to be going better, you have overlooked
something.

the job doesn’t stay on xp “spooling”, it only appears for a fraction of a second and then disappear …

but tx …

On 2010-06-26, eroskoller <eroskoller@no-mx.forums.opensuse.org> wrote:
>
> the job doesn’t stay on xp “spooling”, it only appears for a fraction of
> a second and then disappear …
>
> but tx …

Is there any activity on the printer, even briefly?


Any time things appear to be going better, you have overlooked
something.

type myfile.txt > lpt

doesn’t go through the XP spooling system, it sends it directly to the device. How have you set up the printer under XP? You should set it up so that you can print from say notepad, without any conversion of text to anything else.

Its not apparent how you have configure the printer on the windows print server. Further to ken_yap’s advice, don’t forget to share the printer, and configure your cups client to point to your remote raw printer queue. Assuming you configured CUPS via lpadmin CLI or via http://localhost:631/