Printing issues!

I’m not sure if this is a 64-bit issue or not, but I can’t seem to get my printer to work. I’m currently running 11.0, but I had the same problem with 10.3.

I have an HP Deskjet F4180 which whenever I try to print will print out the page, but in color rather than black and white. A page of black text will print red and then fade to green. It isn’t an issue with the printer since when I boot into Windows it works fine, it only does this with Suse.

Any help or suggestions would be much appreciated. It is rather annoying to have to boot to windows whenever I want to print something.

I have experienced something similar to this and even went to the trouble of changing the settings before printing to make the printer use only the black ink. I can’t really tell you what the problem was, but after I replaced the inks with new ones, it worked fine. But in my case the printer was starting with black then switching to red.

Do you have a HP Device Manager? Is HPLIP installed?

It sounds like it could be the same problem, it will often start black for half a page or so then switch to color. I also have tried changing the settings to no avail. It seems strange that getting new ink would make a difference since it works fine in Windows, but perhaps I’ll give that a try.

Yes to both.