Printer setup - not printing

I just set up my HP F2100 printer and it looks like its set up correctly, but when trying to print, nothing happens.

What could be missing?

(running opensuse 11)

It should work. I note this from the linux printing page:
OpenPrinting database - Printer: HP DeskJet F2100

Make certain you have the application “hplip” installed. Then go into yast and reconfigure the printer.

I had the same problem. Seems the hplip 2.8.4 that comes with Opensuse has a problem the fix maybe hplip 2.8.6 problem solved by going here:
HP Linux Imaging and Printing (HPLIP)
There is a self extracting package there does everything for you & complete instructions there with screenshots. I just did it & now mine works!

I ran hplip and it shows that its set up and configured… but it doesn’t print.

How do install the new version of hplip? I just downloads a run file and what do you install it with?

…well I got it to printer from Firefox, but not in OpenOffice.

What would be the difference?

This is very confusing to me, too. My HP would not print no matter what I did. CUPS would not let me add a user. I ended up ininstalling and then re-installing cups. After that, it accepted root as user and root’s password. After that, I was able to add my regular user. The normal suse trick of
lppasswd -a vinoman2

still does not work for me. However, I am printing.

To complicate things, the test print I was using was from the internet. It was a pdf file that opened in okular. But, I spent hours trying to get this pdf to print before I noticed that okular was ONLY printing pdf’s and, sure enough, I had a load of copies of this file “printed” in my /home directory.

My solution was to install Adobe Reader. Firefox and OpenOffice work just fine, so I can’t figure out why only some apps work. Sorry to say, I can only suggest you find a workaround for each file that is not printing… until they get this fixed.

the difference might be configuration.
print again in firefox. and take note on how firefox communicates with the printer. and mimic the configuration in openoffice.

You’re right, I have two listings and the hp2100 is the one that works! Thanks. :slight_smile: