Printer problems after upgrade to 11.4


Yesterday I upgraded my computer from 11.3 to 11.4. Everything looks very nice and cool so good job guys.

The only problem i have this far is my printer (It’s a HP C4580 All-in-one). The colors are inverted in every print job i send to the printer. Black works fine.

My other machine that is not upgraded yet works fine and i have tryed to reinstall the printer.

My hp-lip package is: hplip-3.11.1-6.1.x86_64


I am encountering the same problem, and it is driving me batty!! Same box booted with Debian Squeeze works fine!

I have two printers connected. The Canon PixmaMP540 (all-in-one) works ok when the manufacturer’s driver has been installed. The other, which is a Minolta PagePro1300w, has been a problem. At first it was not found, although both machines are connected via usb. Eventually I did manage to get it “recognised” but even though I installed the driver found at Linux Printing it still did not install.
Incidentally, I have tried the same printer on other distros all 64 bit and it installed straight away without any additional driver needed.

@mr-vein: Did you try configuring via the ‘hp-setup’ utility? Or via YaST? (The former is recommended). Did you try the hpijs driver? (I’ve seen reports that the openSUSE 11.4 hplip driver causes problems for some users).

Did you try the alternate PPD driver? In yast there’s usually two choices, with one tagged “preferred”.

Also in 11.4 I tried to configure an HP p1005 laserjet with hplip, it would set ok and communicate (show toner level, status, etc.) but the print jobs wouldn’t start. After removing and reinstalling it in yast it is working. The first setup with hplip was necessary as it downloads the required non-opensource firmware that I couldn’t find as a separate download in HP’s site.

Hi Again

First of all, sorry for not answering here right away. I had a death in my family (my grandfather), and i forgot about this issue. Please dont hate me for it.

Secondly, I tried to change to hpijs driver and not it works perfectly. Thank you.

On 2011-04-26 21:36, rprigan wrote:
> I am encountering the same problem, and it is driving me batty!! Same
> box booted with Debian Squeeze works fine!

Two people with the same problem? I hope you report in Bugzilla. Both of
you, one writes, the other adds a comment me too.

Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

I have reported it now. Bug: 692905.

(My first time in bugzilla :))