Printer problem

I am running 42.2 in my desktop box. My Samsung ML 2010 is connected to another box running 42.1. I can’t print from 42.2. So I booted 13.2 on my desktop and after making sure I could print normally I copied all the settings from YaST (13.2) to YaST (42.2). HOWEVER on the Printer Configuration screen (42.2) the printer shows up twice and tells me it’s connected “Local” instead of “Remote”. Furthermore I cannot delete either printer entry. When I tell it to delete it just comes back again. Really odd behavior.

Any suggestions?

So if I understand you correctly, you have a CUPS server running via your 42.1 machine with a shared printer. Recent CUPS versions (1.6+) use DNS-SD to automatically discover and access shared printers, so there should actually be no need manually configure the printer on the 42.2 client machine.

Show us the following…

lpstat -t

Sorry, for avahi-discovered printers use

sudo /usr/sbin/lpinfo -v

For example, I get my Brother printer (connected to another Linux machine on my LAN) reported as

network dnssd://Brother%20DCP-7055%20%40%20linux-54cw._ipp._tcp.local/cups
:~> lpstat -t
scheduler is running
no system default destination
device for Samsung_ML-2010: implicitclass:Samsung_ML-2010
device for samsungml2010: implicitclass:samsungml2010
Samsung_ML-2010 accepting requests since Fri 09 Dec 2016 08:31:23 CST
samsungml2010 accepting requests since Fri 09 Dec 2016 08:31:23 CST
printer Samsung_ML-2010 is idle.  enabled since Fri 09 Dec 2016 08:31:23 CST
printer samsungml2010 is idle.  enabled since Fri 09 Dec 2016 08:31:23 CST

:~> sudo /usr/sbin/lpinfo -v
root's password:
network beh
network lpd
network http
network ipp
network ipps
network socket
network https
direct hp
network smb
network dnssd://Samsung%20ML-2010%20%40%20linux-45y1._ipp._tcp.local/cups
network dnssd://Samsung%20ML-2010%20Foomatic%2Fgdi%20(recommended)%20%40%20linux-45y1._ipp.

Thanks for the quick responses.

You have the printer defined twice in your print server (linux-45y1 machine). One is using the foomatic driver…

network dnssd://Samsung%20ML-2010%20%40%20linux-45y1._ipp._tcp.local/cups
network dnssd://Samsung%20ML-2010%20Foomatic%2Fgdi%20(recommended)%20%40%20linux-45y1._ipp.

There will be two entries in/ etc/cups/printers.conf of the print server - one for each definition. Do they both work? Try printing using each one from the print server (openSUSE Leap 42.1 machine).

Thanks for the help. I deleted one. I kept the “foomatic” (recommended) configuration and everything now works.

That’s good to know. :slight_smile: