printer only prints 1/4 of the page

Hello everybody rotfl!,

I have a problem with my printer: Since I have installed OpenSuse 13.2 my printer doesnt work longer… Yesterday I installed an cups-libs update (with zypper dist-upgrade). Since then it print 1/4 page in the mid of the page. When I have OpenSuse 13.1 it works perfect with the same driver (driver from Samsung).

My printer is: Samsung m2070mw. Here is an url (http://i.imgur.com/9l5BHFu.jpg) to a picture where you can see the result from a test page.

I dont know what to do…?! I hope someone can help me. Thank you very much!
greets k3jj3k

edit: link fixed

Same thing here with an HP Officejet 7500a with cups or hplip; on any other distro I get my prints alright

Why did you do ‘zypper dist-upgrade’? It is usual to update using ‘zypper up’. Which repos do you have enabled?

zypper lr -d

Maybe a good idea to post the output from the following command too

rpm -qa|grep cups

Why did you do ‘zypper dist-upgrade’? It is usual to update using ‘zypper up’. Which repos do you have enabled?

I always use ‘zypper up’ to update my system, but it said me ‘there is noting to do’. But with ‘zypper dup’ there were a few updates, including ‘cups-libs’, so I did it.

I’ve only the standard repos:

# | Alias               | Name                         | Enabled | Refresh | Priority | Type   | URI                                                          | Service
--+---------------------+------------------------------+---------+---------+----------+--------+--------------------------------------------------------------+--------
1 | repo-non-oss        | openSUSE-13.2-Non-Oss        | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/non-oss/ |        
2 | repo-oss            | openSUSE-13.2-Oss            | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/oss/     |        
3 | repo-update         | openSUSE-13.2-Update         | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2/                    |        
4 | repo-update-non-oss | openSUSE-13.2-Update-Non-Oss | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2-non-oss/            |        



Maybe a good idea to post the output from the following command too

Sorry, I forgot it:

python-cupshelpers-1.4.5-2.5.1.noarch
python-cups-1.9.66-2.1.3.x86_64
cups-pk-helper-0.2.5-4.1.4.x86_64
cups-1.5.4-21.3.1.x86_64
cups-libs-1.5.4-21.3.1.x86_64
cups-filters-ghostscript-1.0.58-2.1.3.x86_64
cups-filters-foomatic-rip-1.0.58-2.1.3.x86_64
cups-libs-32bit-1.5.4-21.3.1.x86_64
cups-client-1.5.4-21.3.1.x86_64

Thank you for your replies!

edit: add repos

Well, I guess you can try downgrading again

zypper in -f cups-libs

You should be presented with some options. Just follow the prompts given.

See how that goes.

I tried it but no result…

output of the command:


Loading repository data...
Reading installed packages...
Forcing installation of 'cups-libs-1.5.4-21.3.1.x86_64' from repository 'openSUSE-13.2-Oss'.
Resolving package dependencies...

The following package is going to be reinstalled:
  cups-libs 

1 package to reinstall.
Overall download size: 620.5 KiB. Already cached: 0 B  No additional space will be used or freed after the operation.
Continue? [y/n/? shows all options] (y): y
Retrieving package cups-libs-1.5.4-21.3.1.x86_64                                                                                                       (1/1), 620.5 KiB (  4.7 MiB unpacked)
Retrieving: cups-libs-1.5.4-21.3.1.x86_64.rpm ..........................................................................................................................[done (288.9 KiB/s)]
Checking for file conflicts: .........................................................................................................................................................[done]
(1/1) Installing: cups-libs-1.5.4-21.3.1 .............................................................................................................................................[done]

Does noone else an idea? Please, I need to print… :confused:

You may find some clues in

/var/log/cups/error_log

As a last resort, possibly try changing drivers to the ULD provided by Samsung themselves if you’re using the OSS drivers, or vice versa.

Although Ubuntu oriented there is a lot of good info here: http://bchemnet.com/suldr/index.html

Okay, in another recent thread, the following bug has been reported

https://en.opensuse.org/openSUSE:Most_annoying_bugs_13.2#Printing

The workaround mentioned was as follows

Workaround: Re-install cups-filters-ghostscript and restart cupsd (as root run “zypper install --force cups-filters-ghostscript” and “rccups restart”)

So, hopefully this will help you too.

That works for me! Thank you very much

greets
k3jj3k

I’m glad that this has resolved your printing issue. Thanks to the others for reporting the bug.