Printer not listed HP D1300

Hello, Just tried Suse open edition and everything seems to go great with the exception of my simple HP printer. It detects it properly but cannot find a model type. I went to select from a list and it is not listed. I tried several others there but no luck. Any help would be appreciated. Printer works fine with Ubuntu or PClinux so I know It works just fine.

What is “Suse open edition”? Can you tell us exactly which version of openSUSE? 10.0 ? 10.1 ? 10.2 ? 10.3 ? 11.0 ?

Also make certain you have hplip installed.

HP have this to say about the D1300 series:
Deskjet d1300 Series

11.0 is the version yes it is opensuse and yes hplips is installed.I am using the KDE4 desktop and have had a few conflict issues seems mostly to Ktorrent needing to be removed for other things to work. Not sure if this has anythin to do with this issue, but I have tried everything I know to get this printer to work. Ubuntu 8.04 installed it and I did nothing and I guess I forgot other systems were different. Well, let me know what you find out.

Also, it detects the series not the model. Model is not listed in all the deskjet listings. Is there a comparable model that might work with it?

ktorrent works fine on KDE-3.5.9 in openSUSE-11.0. NOTHING special needed. It JUST WORKS.

Is Ubuntu using 2.6.25 kernel and also using KDE-4 ?

Apologies, but I can offer some suggestions based on the minimal experience I have, but thats all. I have no investigations planned to find out anything further than that.

Did you try the other models?

I notice the HP D1300 series have a postscript option. Does yours have that option? If so, just try the post script printer driver.

Also, before you installed, did you do a comparison of the md5sum on the openSUSE web site against the md5sum of the iso file on your hard drive against the md5sum that can be calculated from the data on your burned CD/DVD?

And finally, if I can rant a bit … why go to KDE-4 from Gnome (in Ubuntu), when KDE-4 is known not to be all that stable? :rolleyes: Go with a stable openSUSE desktop (KDE-3.5.9) and IMHO your experience will be a lot more pleasant.

Ok, stable is 3.5 KDE basically is what you are telling me. Maybe I will try that and KDE 4 may not be ready for any actual real world everyday production work. I am beginning to see that light. As for the printer, I did remove OpenSuse and will do a re-install with the 3.5 desktop. As far as Ubuntu, I use gnome desktop, no problems what so ever, just wanted something fresh. If all else fails, I will return to trusty but true…the one the only…Ubuntu…No pun intended. I will keep you informed and will try the post script setting also.

How is the printer connected? If it’s USB, the specificity won’t matter (nice thing about CUPS; if it sees it, it can print to it). CUPS (in all the operating systems that use it, which includes not just Linux, but the BSDs and Solaris as well) is what I have referred to as the non-Windows version of Plug-N-Print.

  1. Connect the (USB) plug from your printer to the PC In Question.
  2. That’s it; you’re ready to print.

I have a different model DeskJet (the old-and-growing-mold 940C) and CUPS has never failed to recognize it. Not in any distribution of Linux (whether installed or live media or Knoppixed) or Solaris, or BSD.

Some folks try multiple desktops (or combine apps from multiple desktops). Despite my having GNOME as my default desktop, several KDE apps are more stable than their GNOME counterparts (for example, my default BT application these days is KTorrent in KDE4 form; it’s decidedly more polished, believe it or not, than Monsoon, GNOME’s BT app of choice, which tends to stall out with no warning). It is for exactly this reason that I have GNOME and both versions of KDE (3.5.9 and 4) installed.

A lot of us try Linux (or even use Linux) because we don’t want to be hemmed in. Why let yourself get trapped into a single family of apps just because they aren’t from your usual desktop?

Same problem here with my HP Deskjet 6540. Had to install hplip and run hp-setup as root to get my printer to work.