Printer is printing after reboot

I have an HP C4795 printer and lately when I print something nothing happens until I reboot and then the printer will print. How can I fix this problem? This was printing from Okular pdf reader.

I’m running openSuse 11.3 KDE 64 bit.

Use lpq to list the print jobs in the queue and lprm to remove them.
Read the manpages for syntax: man lpq ; man lprm

Do you have the same symptoms in openOffice or other apps?

I get this:

davek@linux-fvw1:~> lpq
lpq: error - no default destination available.
davek@linux-fvw1:~> su
Password:
linux-fvw1:/home/davek # lpq
lpq: error - no default destination available.
linux-fvw1:/home/davek #

what directory should I be in?

Could you just type it this way instead :

su -

Notice the space after the “u” and the “-”.

And try the command provided by please_try_again another time.

Do you have the same symptoms un other apps than okular?

OK, now I get this:

davek@linux-fvw1:~> su -
Password:
linux-fvw1:~ # lqp
If ‘lqp’ is not a typo you can use command-not-found to lookup the package that contains it, like this:
cnf lqp
linux-fvw1:~ #

what other command goes with it?

the printer works fine with Open Office writer.

Good. Does it works fine in Firefox, Kwrite, etc.?

So it seems the issue comes from okular.

On 2010-11-04 16:36, vinoman2 wrote:
>
> please_try_again;2248322 Wrote:
>> Use lpq to list the print jobs in the queue and lprm to remove
>> them.
>> Read the manpages for syntax: man lpq ; man lprm
>
> I get this:
>
>
> davek@linux-fvw1:~> lpq
> lpq: error - no default destination available.

Then specify the printer name, or configure a default printer.

He also told you to use “man lpq” - if you had, you would have seen that
there is an option to see all printers.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)