Printer enable by default

Is there a way to have my pritner enabled by default on 11.4? Everytime I reboot it doesn’t set it to enabled.

Any help?

More specs please. Printer, how did you configure it, etc.

This annoyed me until I got used to it. When you add a printer using YaST it is not enabled. You can go back into
YaST >> Hardware >> Printer
select the printer then Edit, wait for all the avilab;e printer definitions to load, then select Enable., OK, OK, Quit

or as root from a terminal e.g. (my printer is called CLP500):

giulia:~ # lpq
CLP500 is not ready
no entries
giulia:~ # lpadmin -p CLP500 -E
giulia:~ # lpq
CLP500 is ready
no entries
giulia:~ # 

This has the same effect as enabling with YaST

eng-int, does doing it in Yast keep it enabled after reboot as well?

I ended up putting the cupsenable command in my .bashrc as a work around.

You need to find out why the spooler is being disabled. Unless you tell us what hardware and software you are using, and what is happening (logs), how can you be helped?