Printer drivers Dell 5210n mono and Dell 3110cn colour not available in Leap 15.1

I have installed Leap 15.1 but drivers are not available for my two Dell Printers 5210n mono and 3110cn colour. I had no problems using these printers with Leap 43.2. Will Suse be providing drivers for these printers or alternatively can anyone suggest another solution, please?

The openSUSE distro makes available the same open-source CUPS drivers as any other distro for a given version. What’s important is determining the appropriate driver(s) for a given printer model. Some vendors support Linux with proprietary drivers, other’s leave it to the open-source community to write drivers.

Anyway, from a quick search online(Ubuntu wiki page)](https://wiki.ubuntu.com/HardwareSupportComponentsPrintersDell), it seems that the Dell 5210n model may be supported by a (Dell M5200) postscript driver. As such, install the ‘OpenPrintingPPDs-postscript’ package

sudo zypper in OpenPrintingPPDs-postscript

then proceed with configuring via the CUPS web interface

http://localhost:631/admin

Select ‘Add Printer’, enter ‘root’ and the root password, and follow the prompts given to get your printer configured.

I don’t know what drivers you had previously been using with 42.3. openSUSE only supplies open source drivers, and neither of the two models you quote are listed at openprinting.org

http://www.openprinting.org/printers/manufacturer/Dell

Perhaps Dell provides (proprietary) linux drivers, have you checked their support site ?

The Dell 3110cn model may also be supported by the same postscript driver. YMMV.

It would appear that Dell do indeed provide linux drivers for both printers… if the OP wants to go down the non-oss path.

3110cn: https://www.dell.com/support/home/uk/en/ukbsdt1/drivers/driversdetails?driverid=r130088

5210n: https://www.dell.com/support/home/uk/en/ukbsdt1/drivers/driversdetails?driverid=r203686

Actually, they’re postscript drivers (specifically configured PPDs for the respective models), both open-source (relying on foomatic-rip).

OK… Didn’t download and look to see what the packages contained. Note to myself… don’t jump to conclusions.

Many thanks Deano and Paul. I tried to download the drivers from the Dell site but was unable to locate the drivers. I then installed the ‘OpenPrintingPPDs-postscript’ package using YAST2 and installed the Dell M5200 postscript driver and used this for both printers. Both printers produced correct Test Prints including colours from the Dell 3110cn. The 5310n is OK. The 3110cn is OK including colours on documents, however colour pictures are printed in mono. I don’t know if this is because Leap 15.1 does not include The Gimp? I would appreciate any further suggestions you may have. Many thanks again.
Terry

No, gimp has nothing to do with this (and in any case you can always install that at your leisure). It may be that the M5200 PPD isn’t quite right for describing the 3110cn printer’s abilities properly.

Anyway, you mentioned that you had downloaded the drivers. For the 3110cn, the downloaded RPM package is probably in your ~/Downloads folder. Locating and right-clicking on it an using the package manager (eg Install/Remove Software option in KDE) should be enough to get ‘Dell-Color-Laser-3110cn-noarch.rpm’ installed. After that you can configure CUPS to use that driver. When searching under Dell, it was displayed to me as ‘Dell Color Laser 3110cn v3015.103 PS’

I installed the driver (for test purposes) from a terminal using zypper…

sudo zypper in ~./Downloads/Dell-Color-Laser-3110cn-noarch.rpm

Once you have CUPS correctly configured, try printing a test page via the CUPS web interface… Printers > Maintenance > Print Test Page

Thank you very much Deano. I went to Yast2 and found further Printer packages which I downloaded. When I ran the Yast2 installation again I found a driver - Dell 3100cn Foomatic/pxlcolor and installed this. Problem solved.
Best regards, Terry.

Thanks for the update. Good to read of your success with your printers.