Print Screen shortcut not functioning

The Print Screen shortcut not functioning on any installation of 15.2 (KDE) in my house. There are several reports of the Print Screen shortcut not working on older versions of Suse, but I see no current discussion. Since this affects every OpenSuse installation I have, I’m rejecting the idea that it’s a hardware issue, nor unique to me. I’m using default settings, Spectacle should capture a screenshot & open, but nothing is happening.

Any suggestions?

Please explain what you think the Print Screen shortcut is. Other people may have different ideas about that. To make oneself better understandable while describing a problem, it is always good tho explain as clear as possible, what one does, what one gets ans what one expected to get. Specially the first part is missing IMHO.

Same here, works fine. Did you check the settings in Spectacle? After starting it from the KDE starter, there is a button down left next to “Help”. I hope I get translation right, it should say “Settings”. After hitting that you can tell the program what to do after hitting the “print-screen” key, which is what I suppose you were doing. I have set “take a new screenshot”, the boxes whether to copy it into the pastebin or autosave are unchecked.

Thanks for letting me know someone had it working! I got a little more aggressive: A few things I tried did not work, but what did work was completely removing both Spectacle and it’s shortcuts, rebooting, reinstalling Spectacle, then re-entering the print-screen shortcut (telling it that it was OK to overwrite the default).

Now it works like it’s supposed to!!!

I still do not know what you press exactly, but when you are interested if it works here, yes, when I press the PrintScrn key on (on my keyboard directly at right from F12), Spectacle starts. And that is also what I expect. It does so already for ages, even if it wasn’t always Spectacle that started, but some other screenshot program years ago.