Print screen button not working

Hi,

I did a clean install of Leap on my GF’s laptop. HP Notebook. It appears the Print Screen button doesn’t invoke a screenshot. The button has a double function (with Fn pressed) as Insert. Insert works, so the button isn’t dead.

In the shorcuts window the button is set as Print Screen and you can also re-set it as Print Screen. Yet, it will not make screenshots.

From the command-line I can run gnome-screenshot and it will make screenshots and put them in the ~/Pictures directory.

But this is hard when trying to make a screenshot of full screen apps. I also tried to swap Insert (Fn + Print Scrn) with Print Scrn but then, Insert still works and Print Screen still doesn’t.

Does anyone have an idea as for why the Print Scrn button isn’t working?

No idea why you’re experiencing your problem,
But typically screenshot apps have the ability to specify special keystroke combinations to take snapshots (I don’t know about your Gnome app, but that is the case in KDE).

So, it won’t solve your problem directly, but should provide a satisfactory solution.

TSU

I’m having the same problem with my desktop. Print screen button doesn’t do anything. Any idea how to fix this? There has to be some printscreen setting = false or something like that in one of the configuration files, but I don’t have any idea where to look.

Is this about KDE?

The old ksnapshot has been replaced by a new application named spectacle.
You might have to reconfigure the keyboard shortcut to run spectacle instead.

See “Configure Desktop”->Shortcuts->Custom Shortcuts.

Your existing shortcut probably still tries to run ksnapshot.

To fix it I went to settings -> shortcuts -> custom shortcuts and hit right click, new global shortcut, command. From there I assigned the printscreen button to the ksnapshot command, and it is back and working. Not sure why that was necessary, but it did the job so far.

Erm, you shouldn’t have ksnapshot installed any more, or do you?

Btw, there should be an existing one below “Predefined Shortcuts” that runs ksnapshot, do you not have that?
If you do, you should probably delete it, or change it and delete the new one you created.

Not sure why that was necessary, but it did the job so far.

Well, another upstream change (as mentioned, ksnapshot got replaced by spectacle) that should “just work” but apparently doesn’t on (some at least) existing user’s systems.

Broke mine but was easy enough to redo once I’d figured Spectacle had replaced Ksnapshot :stuck_out_tongue:

If this happens to you, here’s what you do:

  • Logout
  • Log in
  • Systemsettings - Shortcuts
  • In Custom Screenshots, there now is a new entry called Screenshots, open the tree structure
  • Click “Start Screenshot Tool”
  • Click the “Starter” tab, the hotkey will have no value, click it and hit PrtScr, accept replacing the current command
  • Done

The problem exists in Gnome, as could be deducted from my opening post :wink:

Assigning the key doesn’t work, hitting the key does nothing with the new key assignment.

Do you have an HP laptop? I could NEVER make this work in a couple of them (oS 13.1 and 13.2).

More info here: https://forums.opensuse.org/showthread.php/494944-prt-scr-shortcut-not-working-in-oS-13-1-KDE-4-12?p=2621560#post2621560

No solution, sadly…

With stock settings of KDE Plasma Workspace in openSUSE Leap 42.1 installed from scratch:

System settings — Workspace — Shortcuts — Global keyboard shortcuts

  • PrintScreen
    action (PrtScr) seems to have no effect at all, regardless of key assignments: even if some other combination is bound to Global alternate shortcut for this, nothing happens upon pressing that;
  • Take active window screenshot
    (Win+PrtScr) — works as expected;
  • Take full screen screenshot
    (Shift+PrtScr) — works as expected.

So it looks like the generic PrintScreen action is simply not handled. The solution is to use the more specific shortcuts.

On Tumbleweed here with same behavior.

I seem to have fixed it by:

System Settings → Workspace → Shortcuts → Global Keyboard Shortcuts

Select “System Settings” from the KDE component dropdown

Select “Start Screenshot Tool” and then (re)assign the PrntScr key to this rather than “Print Screen”

It’s an HP yes.