Print Screen button doesn't work in LEAP

I just tried the print screen button on my laptop’s keyboard for the first time since upgrading to LEAP and it doesn’t work. It does nothing. It worked in 13.2.

I tried changing the shortcut to “/usr/bin/spectacle” but it still doesn’t work. (Running that from the command line does bring up spectacle however)

How do I figure out why it’s not working and fix this?

Using KDE with LEAP

I finally got it to work by hitting shift+prtScr first (that brought up a notification) and now regular print screen works.

Can someone tell me why openSUSE LEAP, which doesn’t include ksnapshot, left the shortcut pointing to ksnapshot?

AFAIK, ksnapshot was shipped with the original release of Leap, then along came spectacle…

I wasn’t up on this either. Just checked the new utility now - a little bit of functionality removed (no rectangular region selection now?), but other than that it works ok.

Spectacle has rectangular selection in tumbleweed.

Thanks conram. Now that I’ve found more time to play, I can launch spectacle from a terminal and note that it does have all the expected/required options. It was just the keyboard shortcuts that were producing instant captures without the UI being present. Got the hang of it now. :slight_smile:

Hi Deano,
Can you please confirm if, when you select “save”
it automagically save without prompting for a file name/title.
I kind of dislike it, because when you have a lot of images
it is hard to find the new image if you don’t know the name/title.:\

Yes, there is a ‘Save and Exit’ button, as well as 'Save and ‘Save As’ options. The default save directory is configurable as well which is nice. I think it is an improvement on ksnapshot.

Even using the keyboard shortcut, you can still do rectangular region. After clicking the shortcut, in the window, pull the dropdown (in the upper right) to “Rectangular Region” and then click to take it again.

The working KDE global keyboard shortcuts I have defined for ‘PrintScreen’ only provide instant screenshots, and a subsequent ‘Spectacle’ notification.

I have…
[Shift]+[Print] configured for ‘Take Full Screen Screenshot’
[Meta]+[Print] configured for ‘Take Active Window Screenshot’
There is a shortcut for ‘PrintScreen’ itself, but that does not seem to launch the utility UI. If I launch the utility manually, then of course I do see the ‘Capture Mode’ presented and can selec as required, as I mentioned previously.

Same problem with my 42.2 on a Toshiba Portege R930.
I fixed reassigning this option:
system settings (Impostazioni di sistema) → workspace (spazio di lavoro) → shortcuts (scorciatoie) → personal shortcuts (scorciatoie personalizzate) → screenshots (schermate) - launch tool for screenshots (avvia lo strumento per le schermate) → Activation (attivazione) → shortcut (scorciatoia) … it was empty, I set to “Print” (pressing the prtsc key and accepting to reassign the key).

Sorry, I have a system set in italian language (I tryed to translate), so english labels may be inaccurate.