Print Probem for non-english files

**Hi all,

I am a new user for the opensuse and linux generally, I have a Lexmark T640 printer and installed it on the leap 42.2 KDE also i made a print test which is ok (printed).

But I can’t print files on Libre office, I tried to convert it to PDF then tried again. It is printed only for english PDFs but for arabic it did not work. I got an error msg on printer screen about software.

Welcome to openSUSE Forums abouzeid007. Please use the default font when posting. It’s easier on the eye.

Check the language settings in LibreOffice : Choose Tools > Options > Language Settings > Languages

This might be helpful to you…

deano_ferrari , thanks for your reply.

Well, the problem also with the Okular Pdf app. I think its about sending data from the leap 42.2 to the printer i.e. it does not recognize the language.

Yes, but the CUPS is only processing graphical PDF data, so maybe you need to check your desktop locale etc

Could you explain more what do you means by desktop local?, and how to check CUPS?

There is a system language for the system functions and then there are local language primary and secondary for each user. Remember Linus is multi-user

Just to clarify - I take it that you can view the PDF documents okay, but the problem is only when attempting to print them? Or is is a problem with both?

Yes,i can view the PDF on both languages but only print english PDFs. even if there a PDF file contains both languages in different paragraphs it did not print.

This might require a bug report then.

From the Okular Print menu, what happens if you select Print > Options > PDF Options, ‘Force Rasterisation’. Does that result in successful printing? (I would expect it should work since it should then treat the PDF as an image.)

Also, when you examine File > Properties > Fonts for given PDF, what fonts are listed?

Yes it works with the ‘Force Rasterisation’ option Thanks. Is there something to make this option permanent.

Here are the Fonts.

I’m not certain, but I don’t think it’s possible to set this option permanently. BTW, if you print to file first and then print that file, does that also work?

You might want to raise a bug report for this. I would have thought PDF files with embedded fonts should print fine.

How could I make a bug report?

It’s not hard, but make sure that you read this guide first

In particular, for a printing-related issue

Here’s where you report (same login credentials as the forum)

It is probably a good idea to include a ‘problem’ pdf example as well.