Primary repository for each package?

I’m running opensuse 11.1 x86_64 and have a (fairly) basic package management question.

Currently I update packages by scanning the packages under @System (under Yast Control Center -> Software Management -> Repositories) and see which ones are blue.

Unfortunately, I’ve noticed that more and more packages are turning red. I take this to mean that the primary repository for that package does not have the latest version installed and so marks it as red. How do I set a particular repository to be the primary repository of a package so that it stays current w.r.t. its package?

Hi,

What packages in particular are you talking about? And what Desktop Environment are you using?

Also, you don’t have to manually go through and find packages that need updated. At the top of Software Management you’ll see a menu called Package. Click that then choose All Packages. Then choose Update if newer version available. This will automatically update any package that’s marked blue.

Good luck,

Ian

No packages in particular, just packages in general. I’m using KDE4.1

The method you describe doesn’t show packages marked in red which the system has deemed to be newer than available versions. For example, right now it doesn’t show libxine as having a new package (1.1.16.3-0 from packman) available since it claims that the 1.1.15-23.3.3 version from repo-update to be the most recently available version. Is this because repo-update has greater priority than packman?

Hmm… Well first let’s see what repositories you have active.

Could you please open a terminal and then post the output of typing this:

zypper lr

Here you go.

agape-server:/home/anand # zypper lr

| Alias | Name | Enabled | Refresh

—±----------------±----------------------------------------±--------±-------
1 | google64 | google64 | Yes | Yes
2 | openSUSE 11.1-0 | openSUSE 11.1-0 | Yes | No
3 | openSUSE_11.1-0 | openSUSE 11.1-0 | Yes | No
4 | repo | NVIDIA Repository | Yes | Yes
5 | repo-debug | openSUSE-11.1-Debug | No | Yes
6 | repo-non-oss | openSUSE-11.1-Non-Oss | Yes | Yes
7 | repo-oss | openSUSE-11.1-Oss | Yes | Yes
8 | repo-source | openSUSE-11.1-Source | Yes | Yes
9 | repo-update | openSUSE-11.1-Update | Yes | Yes
10 | repo_1 | openSUSE BuildService - GNOME:Community | Yes | Yes
11 | repo_10 | Main Repository (Sources) | Yes | Yes
12 | repo_11 | Packman Repository | Yes | Yes
13 | repo_12 | openSUSE Education | Yes | Yes
14 | repo_2 | openSUSE BuildService - GNOME:STABLE | Yes | Yes
15 | repo_3 | openSUSE BuildService - KDE:Backports | Yes | Yes
16 | repo_4 | openSUSE BuildService - KDE:Community | Yes | Yes
17 | repo_5 | openSUSE BuildService - Mono:Community | Yes | Yes
18 | repo_6 | openSUSE BuildService - OpenOffice.org | Yes | Yes
19 | repo_7 | openSUSE BuildService - X11:Compiz | Yes | Yes
20 | repo_8 | openSUSE BuildService - Games | Yes | Yes
21 | repo_9 | openSUSE BuildService - Mozilla | Yes | Yes

Alright,

Just making sure you didn’t have any problems with VLC and Packman. Perhaps this will help you out. Check the Priority section.

Repository Management - openSUSE Forums

I think you’re correct that the repo-update has greater priority than packman. The Caf’s post tells you how to fix that.

Good Luck,

Ian