Prey Project not adding device

Probably this forum is not the place to ask, but maybe somebody have solved the same problem before.

Prey allows to locate a lost device, wonderful app by the way, but I’m having problems adding my laptop with Leap 42.1 to my Prey account.

I don’t have any issue installing it from the security repo, and I can even configure it, but even when it says that everything went well, the laptop never shows up in my account. I’m not sure if it’s Prey’s fault, Leap’s, or my laptop is not working.

I thought it was a problem with the firewall, but it does not work even when it’s off. When I run it on terminal, no error message appears.

Summarizing, I did this and didn’t work.

Any tip?


Took a look at this.

Based on the README at

Specifically the section

 -- Windows, Mac & Ubuntu Linux users

Download the package/installer and run it.

Once all files are in place you'll need to configure Prey, where you'll
be able to choose between both operation modes. In case you want to use
Prey along with the control panel (recommended), you'll have to register
and add your device to obtain your API key. Prey needs it so make sure
you add it correctly.

If you want to use Prey in an independent way, you'll have to set up your
mail server (SMTP) settings. Sometimes email sending doesn't work at once,
so please try using a different target mailbox just in case — in fact
that's how the problem generally gets fixed.

I don’t see how to obtain an API Key for any non-debian Linux which is required for working with the web control panel.
Looking at the contents of the package, I don’t see a key generator or other hint how to get a key.
I didn’t try downloading the debian package and then tearing it apart to see if a usable key is in there (There probably is a usable key somewhere, possibly in the config).

Otherwise, according to the above, if you add the crontab entry a little bit lower in the README, I think it’s supposed to email you periodically with info about your machine and where the device is located (of course that means configuring a correct email address in the plain text file… which I don’t know I’d want to do on a device that could be stolen).

So, it looks like you should submit an Issue at the preyproject github repos (Don’t know which one is best - Support? - Web Control panel?)


Thanks tsu2 for your reply and sorry for the delay, but I was waiting for a solution from Prey.

I contacted them and they were helpful, but I couldn’t solve my problem. They insisted in

config gui -f

When it didn’t work (apparently they’re using Ubuntu folder architecture and files in OS are not where they think they are), they told me to remove and install Prey again. A classic “turn off, turn on.”

Summary, I couldn’t make it work and they were not able to help me.


If that’s the case,
Then it really is their fault for either not knowing or not caring to use relative paths (in post cases) instead of fixed paths.


I succeeded in installing Prey but when registering Prey I get the message that my Leap 42.2 is an Unknown OS? :frowning:
I entered an issue report to github about this. They have to add it to the list of known OS’s but no reply yet :sarcastic: