Preventing autologin that happens when KDE can resume my session

I usually shut down openSUSE in KDE by clicking the shutdown icon and selecting “Turn Off Computer”. When I boot back into openSUSE, my session resumes automatically without it asking for my password.

While I don’t mind KDE resuming my session because it saves time, me not having to reenter my password is a security risk. How do I turn off the autologin?

Go to YaST -> Security and Users -> User and Group management -> Expert options dropdown -> Login settings and untick the Auto Login box.

Thanks! I hope that I accidentally enabled autologin during install, because having it on by default is irresponsible in my opinion.

Your welcome. :slight_smile: - The checkbox during the install of openSUSE is ticked by default to enable auto login if you don’t want autologin just untick it either during the install or after in YaST.

In the installer it’s on by default, just like using the password of the first created user as root’s password. But you seem to have missed the option at all :slight_smile: