prevent dhcp-client from setting the default route

Hi openSuSE-Users,

In 11.3, if in “/etc/sysconfig/network/ifcfg-eth0” i set

DHCLIENT_SET_DEFAULT_ROUTE=“no”

this seems to have no effect. If i start my box, the routing table has the “default route”-entry offered by a remote DHCP-Server.

More Info:
My Susebox has eth0 and eth1 and both network devices should use DHCP4.

But from DHCP-offer on eth0 i want to use

  • “offered IP-Adress for eth0”
  • “offered NTP-Server”
  • “offered Host-Name”

From DHCP-offer on the eth1 i want to use

  • “offered IP-Adress for eth1”
  • “offered DNS-Servers”
  • “offered Default Route”

any ideas whats wrong? Thanks a lot

Andreas

You can’t set up 2 dhcp servers with different settings on the same network.
Logically:
The first server that responds will supply the settings. If you are using 2 dhcp servers on the same entwork, it’s usually because you have a large network or need some sort of failover.
To get what you wnat to work, the dhcp servers have to be on different networks and eth0/eth1 wired to separate hubs routers for each network - or if this is not possible, at least have the mac address set as allow/disallow in the dhcp servers.