Pressing Installation on Tumbleweed's boot menu reboots the computer (or abandons the install)


As the title says I’m having issues installing Tumbleweed because after pressing Installation the kernel loads but then the system just reboots after showing a prompt for a split second saying there’s some kind of problem with edd (adding edd=off to the command line does not solve the issue). My computer is a Dell Inspiron 15 5577 and the phenomenon occurs even though I have nomodeset in my boot options.

Has this happened to anyone and how do I solve this ?


Where? Do you mean, when you select Install in the Grub menu?

Or, do you mean after going through the install options and it is ready to install? I wasn’t paying attention when you installed, so did not see what you did.

The former. As soon as I boot on the USB the first menu that appears where it says Installation. That is to say, I cannot access the installation at all.

Okay, I am not certain if this will work in your case, but I have used it in a couple of similar cases and it worked for me.

When you have that Grub Menu up, highlight the Installation entry, but do not click it. Instead, hit the “e” key and add some parameters to the command line.

At the end of that line, add a space, then add:


This updates the Updater for any hardware-related fixes or so forth. This means when you actually start the installer, you will need to wait a few moments or a minute or two for the updates to be downloaded, but not long. It will look like it stalled, but it has not, just wait those moments.

First, though before continuing …

Add another space, then also add this at the end of the line:


This will give you the slightly less-pretty ncurses version of the installer, otherwise functions the same, not that difficult to use, but avoids most graphical hardware issues with the installer.

When I used this method, my first boot after install brought me up into openSUSE and the installed Desktop as I expected to see it.

It is up to you, but you might want to try just the self_update option at first, and if that does not work, then try both options.

Thanks for your suggestions but I found a workaround suggested by my LUG and I installed the Leap version and then I switched repos and did a zypper dup and now its workinproperly

Good to hear!:slight_smile:

… and, thanks for coming back to let us know and to offer the information about the solution that worked for you. Will help someone, I am sure.:good: