Preparing to upgrade/fresh install..............

Well I decided to do a fresh install, up from my current 11.2 i586 to 11.3-x86_64.
(I have always used 32 bit OSes both openSuse and Windows, never SURE that my CPU could use 64 bits. Some googling and a visit to IRC #SUSE leads me to believe that it can (maybe), still not 100% sure…)
Hwinfo |grep cpu here:

An easy little project?, A couple of enjoyable hours giving my PC some TLC? Hmmph!
I started by downloading the .iso, no problems there (!)
Now, I have had problems before with optical drives on this PC. The MB has only one IDE/PATA socket, and seems to not like using both channels on it. I have one SATA drive and one pata. I have tried all combo’s of CS, Master/Slave BIOS adjustments (I have updated the BIOS) etc etc. *(5)
So I had to hack apart my father’s USB enclosure, and installed the drive from it internally to his PC.
I then put my IDE HDD into the enclosure and lashed it up to USB *(1), *(2)
I then put a DVDRW drive on the IDE cable. (I would prefer the CD/DVD to be on the USB, but the circuit board on the enclosure is deliberately designed NOT to fit on to a CD/DVD drive, the board itself covering where the power plug would go. I might, I guess, solder power leads to it, and have a flexible lead, but that is for another day. Maybe.)

I fired up K3b, and wasted a number of disks. I chucked out the DVD drive and lashed up another. Drives do not appear in Dolphin or anywhere else. I waste a few more blanks. Putting a blank in notifier pops up “Empty media” but try to write to it, k3b says “Please insert empty media” *(3)

Eventually d/l and install Brasero It works!

I now at last have an install disk.

I now decide to do some tidying up before partition shuffling
I find that my windows/media partition, on which I store TV Radio etc is read-only (Probably my fault, I wrote the fstab entries myself years ago…)
Unfortunately, my windows install cannot see my media partition, despite it being NTFS and ON THE SAME DISK.
So I

chown stephen:users /windows

Dolphin now sees me as owner. I try to delete files from /windows/D No dice. I don’t want to kdesu dolphin and start deleting stuff, so I try:

chown -Rv stephen:users /windows/D

A million lines scroll past, informing me that I am now the owner…
But Dolphin still says owner=root
Back to google, and I happen across this, by our dear friend Swerdna of this very parish:
HowTo Mount NTFS Filesystem Partition Read Write Access in openSUSE

and I edit my fstab accordingly, TY Swerdna

I now have to start some partition shuffling.

I fire up Gparted.
I get

Could not initialise connection to hald.
Normally this means the HAL daemon (hald) is not running or not ready.

I start hal daemon manually
Try again, same result (4)
I thinks Oh well I have an install disk, so I boot from the .iso, (I have md5 and SHA1 checked the d/l, and I ran media check before booting)
Brilliantly, openSuse powers that be do not include Gparted on the install CD.
I have to go to Windows, and use Paragon HDD manager (Very good BTW). BUT. It refuses to move a partition from one disk to another, even though there is ample room.


  1. USB HDD only transfers at 12 MB/s is this right?
  2. When playing with the USB HDD interface, I attached a Maxtor 3200 120Gb HDD.
    I now have a Seagate Barracuda on there, BUT Windows, openSUSE, and even the BIOS still reports it is a Maxtor 3200. How do I persuade the BIOS that it has changed?
  3. Anyone else had problems with k3b not seeing blank disks?
  4. How do I make gparted run reliably, it runs sometimes, and sometimes not.
  5. Any hardware gurus please explain why an IDE interface has problems using both channels? Is there any update I can do? MainBoard is ASUS M2N-MX
  6. Can I move/copy a partion to another HDD?
  7. I need to keep my /home what is the best way to do this?
  8. Is there a way to list ALL applications currently installed, so I can check to see what I need to install in the new 11.3?

To be continued…
Any answers/advice/abuse gratefully received, here or I will put some of the specific queries in the appropriate forums.
Thanks for reading this far!


home:/home/stephen # fdisk -l

Disk /dev/sda: 300.1 GB, 300090728448 bytes
255 heads, 63 sectors/track, 36483 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x6bf99939

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        4271    34306776    7  HPFS/NTFS
/dev/sda2            4654       16486    95048572+   7  HPFS/NTFS
/dev/sda3           17403       36483   153268132+   f  W95 Ext'd (LBA)
/dev/sda4            4272        4653     3068415   82  Linux swap / Solaris
/dev/sda5           17403       20013    20972826   83  Linux
/dev/sda6           20014       36483   132295243+  83  Linux

Partition table entries are not in disk order

Disk /dev/sdb: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x2a4e2a4d

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb3            2624       14593    96149025    f  W95 Ext'd (LBA)
stephen@home:~> df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/sda5              20G  6.9G   12G  37% /
udev                  885M  224K  885M   1% /dev
/dev/sda6             125G   71G   48G  60% /home
/dev/sda1              33G   23G   11G  69% /windows/C
/dev/sda2              91G   82G  9.6G  90% /windows/D


Here is my computer convinced that there is a Maxtor 3200 drive connected, when there is NOT…

One thing for sure: you cannot change ownership of an NTFS partition. So Dolphin will show no changes.

This is too much questions, too much done all at once. Split up your post in separate questions and post in the appropriate forums.

TY Knurpht, Swerdna alludes to this in his tutorial…
When I chown the Windows part, it does show owner=stephen though…

My ignorance/staying behind. Thought it was still like that. Don’t see much dual boots these days.

There are many new products arrival and the price is lower than before. We accept paypal and other way of payment.
Dear friends
First,Pls accept my Best Wishes to you !
The update of our website have been finished, you can find many newest goods arrival and the price of all the goods is lower than before.We expect to do business with you particularly.
Our company Principle"Best Safety+ High Quality+Fast Delivery+ Good Price = Permanent Customers ".

Our payments way are western union and paypal , just choose the payment you like, If you are interested in our products, please do not hesitate to contact us.
Our company can give you the lowest price,and the best quality products, please contact us soon .
We will be your best brand products supplier.
Welcome to visit our website: Home–Top Quality,Hornest Business,Reasonable Price,Safe Shipping.
Visit our website and free to register as a member of our website, then login and get your member prices. select the styles,colours,codes of the products and Quantity, easy shopping and easy paying online…more about our products and more details , pls feel freely to contact us at:
We will reply you without any delay !
Best regards!
Yours truly