preliminaries of a fresh install of opensuse 13.2 on a notebook

hello dear opensuse-community

i am running opensuse 13.1 - and want to do a fesh install in the next week.

what are the preliminaries of a fresh install of opensuse-linux on a notebook

what do i need to do in order to do a fresh install of linux.:

i need to save the mails (tbird)
i need to save the data as all the passwords for tbird-enigma and things like that

as for the new installation:
should i do the partition with gparted or how !?

Do you want to totally wipe it and start totally new including your data?

Unless you are do extra stuff like web servers and such all you data is on /home back that up and you are safe. In any case back this up justin case something goes wrong.

You can do a clean install but preserve your data on home assuming you have a separate home partition which is default on openSUSE

At the install and the partition scheme section go to expert mode and tell the installer not to format the partition that is your home just mount it as /home. If you use the full DVD and not a Live you have the option of upgrading from the DVD. If you want a true clean install set the root partition to be formatted. Always double check that the installer has chosen the right partitions.
openSUSE now defaults to the BTRFS file system It can cause issues with the hibornation and some form of dual booting. Also it is recommended that you use 2X the space for root than ext4. So you would have to redo your partitions if you use it. To keep the same partition size use ext4.

If you follow gogalthorp’s advice remember that any mysql/mariadb data will need to be backed up using mysqldump first.

hello you both

thx for the hints

i back up all

googleathorp you mentioned this

f you want a true clean install set the root partition to be formatted.

this means - the true clean installlation is an (smart) option - that can be done -…

note i back up all
and i have to rebuild all the things.

especially twith the thunderbird and the enigmail i somethims have had issues int he past - after doing a puprade with zipper dub…
i run into big big troubles

note: i will start with the new installation next week - so i come here again before i will start… :wink:

Note that you must always be aware of what the installer is planning on doing. It can not read you mind so some times you must take control. It is primarily for install on empty disks or dual booting anything more and you need to set things your self the way you want. Also the Live installers are just not as smart and can only do a new install to do upgrades you need the full dvd

hello dear googleathorp

many many thanks for the reply - i did it: i run the installation of opensuse 13.2

Für weitere Einzelheiten siehe fdisk(8).
linux-a9sq:/home/martin # fdisk -l

Festplatte /dev/sda: 465,8 GiB, 500107862016 Bytes, 976773168 Sektoren
Einheiten: Sektoren von 1 * 512 = 512 Bytes
Sektorgröße (logisch/physikalisch): 512 Bytes / 512 Bytes
E/A-Größe (minimal/optimal): 512 Bytes / 512 Bytes
Festplattenbezeichnungstyp: dos
Festplattenbezeichner: 0xb8fa3ecd

Device Boot Start End Sectors Size Id Type
/dev/sda1 63 8385929 8385867 4G 82 Linux swap / Solaris
/dev/sda2 * 8385930 8594774 208845 102M 83 Linux
/dev/sda4 8803620 976768064 967964445 461,6G 5 Extended
/dev/sda5 21382578 42347339 20964762 10G 83 Linux
/dev/sda6 159768576 976766975 816998400 389,6G 83 Linux

linux-a9sq:/home/martin # /usr/share/applications/kde4/konsole.desktop

how do you think about the patition logic?

btw: have found some issues with the network configuration—…

i allways struggle with ifup and knetowkrmanager … At the moment i only can run the notebook with the ethernet wire connected. No wlan is possible

what can i do now;

see some issues that i found out!

!!! CND0120E: the Netzwerkinterface wlp4s0 has got no IP Adress
!!! CND0290E: no networkconfiguration for Interface wlp4s0 found
!!! CND0490E: no Accesspoint with the SSID on the Interface wlp4s0 found
!!! CND0380E: no WLANs at Interface wlp4s0 found. the hardware and drivers are not well configured

what do you suggest

in 13.2 ifup is no longer used a new program called wicked takes its place. But if you connect via wireless best to use NetworkManger. As always it is configured in Yast