Pre-Install Wierd/Faulty partitioning?

As a Newb, last year I installed Mandriva 2007. OK O/S quite liked it. Multi boot with XP.
I ran out of Windoze disk space, (it’s a 250GB SATA), so reduced the size of the ROOT partition and created a new Windoze drive G:

Now Mandriva won’t boot, comes up with a fault on /dev/sda5 (the new NTFS partition), then throws me into a login prompt which will not accept anything.

Am not asking for help to fix Mandriva just some advice as to the best way to proceed with SUSE 11.0 install without giving myself a lot of grief. Disk partitions:

Disk /dev/sda: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x25a5ad84

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1         728     5847628+   b  W95 FAT32
/dev/sda2             729        5372    37302930    c  W95 FAT32 (LBA)
/dev/sda3            5374       30401   201037410    5  Extended
/dev/sda4            7260       11017    30186131+  83  Linux
/dev/sda5            5374        8283    23374543+   7  HPFS/NTFS
/dev/sda6            8284        8573     2329393+  82  Linux swap / Solaris
/dev/sda7           11018       24072   104864256   83  Linux
/dev/sda8           24073       30401    50837661    7  HPFS/NTFS
linux:/home/linux #

sda4 is ROOT
sda7 is HOME

Whilst I of course advocate installing SuSE, you might be able to fix your Mandriva installation by changing the fstab/grub - most likely it’s an issue with the partition layout changing and Linux partitions changing number from 6 to 7 etc.

Anyway, the easiest way to install SuSE would be to nuke the root of course - installing it on /dev/sda4 by formatting the contents and mounting it as / - with any luck the installer itself should already suggest this.

Warning: Make sure /dev/sda7 is not set to format in the partitioner!

Thanks,Chrysantine :slight_smile:
I’m downloading the 64 bit version right now.
I’m guessing the Live DVD is only 32 bit.
Come back later, maybe help someone else.

live is also avail _64


So I downloaded and ran the 64 bit live version.
Did an install from the Live desktop, after carefully partitioning and formatting only the Root partition.
Everything seemed to go OK except after the message “reboot leaving the live CD in the drive”.
Now the system only boots into XP. No dual boot choice.
Letting the system boot from the Live CD does only that.
So now I’m left with no LINUX at all :frowning:
I read somewhere that SUSE puts XP first in the boot order except I get no choice :confused:

did you use a bootloader before, and if so where was it - usually it will be on the mbr.

where did you install the grub bootloader to when installing from the live cd?

what you explain all sounds a bit strange, as you imply that you had mandriva installed which would need a bootloader, probably on the mbr, so where is it now?

explain some more please

Previously I guess Mandriva patched the MBR since I always had a menu of alternative OSs.

So I performed the install twice since I thought that maybe SUSE didn’t patch the MBR the first time and checked the 2nd time that I had chosen where to put the bootloader: on the MBR.

so do you have a working bootloader or not?

Yes. But only for XP. No LINUX. Just going to try the non-Live x86_64 install :slight_smile:

Actually, I realised later you meant do I have a menu when booting.
No. Just goes straight into XP.
I also tried to perform a repair from the non-Live x86_64 but it failed (twice) to install the bootloader. No detail just “Error”

I guess it’s back to Mandriva :frowning:

you must be missing something

you need to go thru and check the installation summaryclick on the boot section and make sure it is installing to mbr of sda
I suspect it has been going to perhaps /boot of sda4

I can try that later but in the meantime I installed Mandriva v. 2008 Spring and it went without a hitch except I get the usual NTLDR missing.

I really would like to try SUSE 11.0

BTW, thanks for your patience :slight_smile:

Well, I went around the loop again. Fresh install and double checked boot is on MBR and /boot.
Now system boots straight into SUSE rescue.
Problem with /dev/sda4 “inconsistencies” which Rescue cannot fix nor fsck.
Looked at menu.lst, no Windows option there.
Shame :eek:

Now system boots straight into SUSE rescue.
So NO Grub menu? V. odd

You say

checked boot is on MBR and /boot
It should just be MBR of sda
/boot is only relevant in that boot info is stored in that dir of sda4 (your root)

the mbr info is not in sda4, but is hidden, At least thats the simple way to explain it.

In the install, bootloader goes to MBR of sda. That’s it.

The NTLDR is a file windows uses to boot, if it gets lost/damaged/deleted - you will get that error

Well, sigh, I’ve been around the same loop again. Several times, (I lost count :frowning: ).
Whatever I do makes no difference.
Whether I have MBR and or /boot selected it still fails to recognise the Windows partition. /dev/sda5?
And it still throws a wobbly about bad headers in /dev/sda4.
I also tried grub-install /dev/sda.

Sorry to say that Mandriva 2008.2 x86_64 doesn’t hiccup.
No problems so far except for it getting Windows boot partition wrong: should be root (hd0,0) not root (hd0,1)

Have to wait for SUSE 12.0 maybe :frowning: