pppoe mtu problem, how to set mtu permanently?

Hi.

When I connect to DSL with pppoe https don’t work, http works.
Solution for this problem is to set ppp0 MTU below 1500, 1500 is default.

sudo ip link set ppp0 mtu 1492
https://forums.opensuse.org/showthread.php/521489-opensuse-liveDVD-tumbleweed-quot-no-connection-quot/page2

This is my
/etc/NetworkManager/system-connections/dsl
[ethernet]
mtu=1492

Now, how to set mtu permanently?
That with NetworkManager conf dsl file don’t work.
Then I restart openSUSE and connect with NetworkManager DSL, mtu is 1500.

It should work, but it didn’t.

Maybe some other place where to set mtu for pppoe?

Try using

[ppp]
mtu=1492

This works,

[ppp] 
mtu=1492

.
Thanks.

But now when I connect to DSL can’t update system.
In “System Tray - Software Updates” is “Network is offline”.
And no “button” for update.

Firefox works, Thunderbird, Chrome, etc works. Only “update is offline”.

Good. (It is the ppp interface that needs the smaller packet size.)

But now when I connect to DSL can’t update system.
In “System Tray - Software Updates” is “Network is offline”.
And no “button” for update.

Firefox works, Thunderbird, Chrome, etc works. Only “update is offline”.

That will happen if using NetworkManager and the connection is not configured as a ‘ssytem connection’ as it starts up after logging in to the DE. The software updater utility is then running before the network is up. Use the connection editor to reconfigure the DSL connection as a system connection by selecting “Allow all users may connect to this network” option. A recent post about that here.

This works, but need restart.