Powernow-k8 problems with 11.2-64

I am testing version 11.2 (Released version) and have this problem (part of dmesg):
13.037249] powernow-k8: Found 1 AMD Athlon™ X2 Dual Core Processor BE-2400 processors (2 cpu cores) (version 2.20.00)
13.037268] [Firmware Bug]: powernow-k8: No compatible ACPI _PSS objects found.
13.037270] [Firmware Bug]: powernow-k8: Try again with latest BIOS.

So Opensuse cannot lower the speed of the CPU-cores. I tried updating the BIOS without luck. powernow-K8 under Opensuse version 11.1 (dual-boot) works perfect.

Anyone who has an idea?

Yep… Same error here on x86_64 kernel while running on a AMD PhenomII X4 965 Processor (stepping 03) in Gigabyte 790FX board with the latest BIOS… I’ll try and turn this into a bug-report…

If you are running the Desktop kernel, did you try switching to default? Or Vice Versa

Take a look at the bug 548108, it look right up our alley. I’m gonna give the suggested success from upgrading the Kernel to kernel-desktop-2.6.32-41.1.x86_64.rpm from the Index of /repositories/Kernel:/HEAD/openSUSE_11.2 repo a try - I’ll reply back here…

Nope, no luck with the 2.6.32-41-desktop kernel… had to lose the repo’d nvidia drivers & preload-kmp rpm, move the tweaked nvidia xorg.conf and recompile the Realtek network driver too !! Also hada buncha “WARNING: All config files need .conf: /etc/modprobe.d/generic_serial-blacklist, it will be ignored in a future release.” errors… coupla things looked better, but still getting the:

kernel:    17.595425] [Firmware Bug]: powernow-k8: No compatible ACPI _PSS objects found.
kernel:    17.595425] [Firmware Bug]: powernow-k8: Try again with latest BIOS.

It’s late, so goodnight for now !! As this clearly worked in 11.1, I’m sure we’re only some kernel tweaks away from success !!

Did I see a comment in that bug report that kernel-vanilla was OK?