Powerdevil doesn't toggle between AC adapter, pluged in or..

Powerdevil has been a pain for me for as long as I’ve use it, since KDE 4.3.1(Even Pre 4.3.1, up to 4.4)… It doesn’t toggle when I unplug the AC adapter and doesn’t toggle between power management modes, so in-turn shuts off immediately without any notification that power has ran out. When I ran ‘acpi’, AC Adapter indicates properly when I unplug it and plug it back in, so I would rule out an ACPI issue, no? Is this a bug in Powerdevil? Anyone would have any idea to the cause of this problem and know how to remedy this issue? I would really appreciate, thank you.

This is a Toshiba Laptop L305D-S59222

I don’t get this behaviour at all. It works well for me, though mostly I don’t let power devil do anything, because I tend to be connected to the AC all the time.

lhorace wrote:
> This is a Toshiba Laptop L305D-S59222

why don’t you try looking around in, or even posting in, the special
forum named “Laptop - Questions about laptop hardware and laptop
specific software (power management)”

might have more luck sorting out the problem–


I have the same issue. I figured that if acpi could do it, powerDevil should too. I tried to check acpi on my wife’s laptop (Kubuntu) and found that acpi was not even installed. Seems my assumption that powerDevil relied on acpi (or acpid) was wrong (not that my wife’s laptop registers the AC properly either).

I’ve done some reading and it seems that powerDevil responds to events (from the HAL?), and does not poll the system. I can’t really find much more detail than that about how powerDevil is supposed to work though.

Can anyone point me in the right direction to research this? Or is there at least a way to make powerDevil check using acpi calls since that seems to work?