Powerbook G4 and 11.1


I just recently installed 11.1 on my Powerbook G4 17inch.

Everything works great besides the normal ppc woes like flash support :’(

But I am unable to get wifi to work nor sound.

For the sound issue I tried the su /usr/sbin/install_bcm43xx_firmware and it downloaded and installed the firmware. I rebooted and then configured the card in yast. Yast can scan the network and see all the available ssid’s but it will never connect to one once configured.

I didn’t try anything for the sound issue, don’t really know where to begin and didn’t find anything on any forums about the issue.

Any help would be much appreciated.

Dean :wink:

Which 11.1 are you running? KDE or Gnome?
64 bit or 32 bit?

Sorry if these questions seem dumb, but it will make a difference for wifi…

On sound, is the Master Mixer on? Again may seem dumb but I can’t tell you how many times… In either version of 11.1 there should be a speaker on a toolbar to adjust that…

Sorry couldn’t be of more help…I personally had to use the 32 bit Broadcom driver on a 64 bit install…that was on 11.0, however, and not a PPC machine…

There is a note from the Ubuntu faq about airport-extreme cards coming up in the B mode, so if your router is set to G-only, then perhaps check to see if you can set the router for B & G mode just in case.

Are you running WPA? If so, I haven’t heard of any successful wpa connections - in fact I had to drop back to WEP 128 bit keys on my Debian Lenny G5 iMac box as I’m not sure if wpa_supplicant works with ppc. (Someone correct me if I’m wrong) I’m also running Netgear WG111v2 and Belkin F5D5070 usb sticks successfully so that might be an option.

See if you can connect at all with your router totally open (if you don’t mind it) temporarily, and broadcasting your ssid. If it works, then tighten things back up.

I also had to delete network manager and run straight from /etc/network/interfaces too, but not sure if that affects 11.1. Some have suggested wicd as a replacement but haven’t tried it.

Whew - but now on to sound. I couldn’t get sound working on 11.1 with my G5, whereas it did work with 11.0 - however one thing I didn’t try was upgrading to the latest ALSA. And, some 17" powerbooks have been known to have sound issues in any ppc distro - but you’d have to check for your specific model.

Which one do you have?

Apple PowerBook G4 17-Inch Support Links @ EveryMac.com

This might help narrow things down a bit.

Did some more digging and have to definitely agree w/ above post on sound…latest Alsa is probably your best bet…

Thanks for all of the reply’s guys, I will work some more on it tonight and let you know what I find out.

Thanks again
Dean :smiley:

Reference your sound, try to work your way through the openSUSE audio troubleshooting guide: SDB:AudioTroubleshooting - openSUSE

Please use this sound test (from a gnome-terminal or a kde konsole):
speaker-test -c2 -l5 -twav